Super Mario

1 篇文章 0 订阅
1 篇文章 0 订阅
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8448    Accepted Submission(s): 3568


Problem Description
Mario is world-famous plumber. His “burly” figure and amazing jumping ability reminded in our memory. Now the poor princess is in trouble again and Mario needs to save his lover. We regard the road to the boss’s castle as a line (the length is n), on every integer point i there is a brick on height hi. Now the question is how many bricks in [L, R] Mario can hit if the maximal height he can jump is H.
 

Input
The first line follows an integer T, the number of test data.
For each test data:
The first line contains two integers n, m (1 <= n <=10^5, 1 <= m <= 10^5), n is the length of the road, m is the number of queries.
Next line contains n integers, the height of each brick, the range is [0, 1000000000].
Next m lines, each line contains three integers L, R,H.( 0 <= L <= R < n 0 <= H <= 1000000000.)
 

Output
For each case, output "Case X: " (X is the case number starting from 1) followed by m lines, each line contains an integer. The ith integer is the number of bricks Mario can hit for the ith query.
 

Sample Input
 
 
1 10 10 0 5 2 7 5 4 3 8 7 7 2 8 6 3 5 0 1 3 1 1 9 4 0 1 0 3 5 5 5 5 1 4 6 3 1 5 7 5 7 3
 

Sample Output
 
 
Case 1: 4 0 0 3 1 2 0 1 5 1
 

这题用划分树做,再用二分法查找。

#include<bits/stdc++.h>
using namespace std;
int n,m,tree[20][100001],toleft[20][100001],t,sortnum[100001];
void dfs(int l,int r,int depth)
{
    if(l != r)
    {
        int same = 0,mid = (l + r) / 2 + 1;
        for(int i = l;i < mid;++i)
            if(sortnum[i] == sortnum[mid])
                ++same;
        int temp = sortnum[mid],num = 0,lpos = l,rpos = mid;
        for(int i = l;i <= r;++i)
            if(tree[depth][i] < temp)
            {
                toleft[depth][i] = ++num;
                tree[depth + 1][lpos++] = tree[depth][i];
            }
            else if(tree[depth][i] > temp ||(tree[depth][i] == temp && !same))
            {
                toleft[depth][i] = num;
                tree[depth + 1][rpos++] = tree[depth][i];
            }
            else
            {
                toleft[depth][i] = ++num;
                tree[depth + 1][lpos++] = tree[depth][i];
                --same;
            }
         dfs(l,mid - 1,depth + 1);
         dfs(mid,r,depth + 1);
    }
}
int findk(int L,int R,int l,int r,int k,int depth)
{
    if(l == r)
        return tree[depth][l];
    int temp,temp1 = 0,mid = (L + R) / 2 + 1;
    if(l > L)
        temp1 = toleft[depth][l - 1];
    temp = toleft[depth][r] - temp1;
    if(temp < k)
    {
        int temp2 = mid + l - L - temp1;
        int temp3 = temp2 + r - l - temp;
        return findk(mid,R,temp2,temp3,k - temp,depth + 1);
    }
    return findk(L,mid - 1,L + temp1,L + toleft[depth][r] - 1,k,depth + 1);
}
int findh(int l,int r,int h,int depth)
{
    int ans = 0;
    int left = l,right = r;
    while(left <= right)
    {
        int mid = (right + left) / 2;
        int temp = findk(0,n - 1,l,r,mid - l + 1,0);
        if(temp <= h)
        {
            ans += (mid - left + 1);
            left = mid + 1;
        }
        else
            right = mid - 1;
    }

    return ans;
}
int main()
{
    scanf("%d",&t);
    int casei = 0;
    while(t)
    {
        ++casei;
        scanf("%d",&n);
        scanf("%d",&m);
        for(int i = 0;i < n;++i)
        {
            scanf("%d",&tree[0][i]);
            sortnum[i] = tree[0][i];
        }
        sort(sortnum,sortnum + n);
        dfs(0,n - 1,0);
        printf("Case %d:\n",casei);
        while(m)
        {
            int l,r,k;
            scanf("%d",&l);
            scanf("%d",&r);
            scanf("%d",&k);
            int ans = findh(l,r,k,0);
            printf("%d\n",ans);
            --m;
        }
        --t;
    }
    return 0;
}




  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值