微信Demo导入遇到的问题

版权声明:本文为博主原创文章,遵循 CC 4.0 by-sa 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/xinluqishi123/article/details/52117087

最近做支付宝和微信接入自己APP工程的功能,遇到了一些问题,跟大家分享:
这里先说Android开发微信支付接入。

首先根据官方文档进行,对比支付宝的官方文档,微信部分更显得“摘要”一些。

导入后自行触发的Gradle Build无法通过,提示需要Android Build Tool 22,所以又安装了22版本;
接下来,报了一个图片不是PNG格式的错误:一般都是最后一个图片,也就是小企鹅图标的那个图片报错,把它用画图程序打开,然后另存为PNG格式的图片就可以了;
然后,诡异了,wechat_sdk_sample_android\app\src\main\java\net\sourceforge\simcpux\Util.java中的 org.apache.http包导入报错;
这是因为该类引用了已经被抛弃的类HttpClient等等一系列和Http底层类有关的引用,我先是将Android的SDK版本和Build Tool降低了两个版本变为如下:

android {
    compileSdkVersion 22
    buildToolsVersion "22.0.0"

    defaultConfig {
        applicationId "net.sourceforge.simcpux"
        minSdkVersion 4
        targetSdkVersion 4
    }

    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
        }
    }

    lintOptions {
        abortOnError false
    }
}

最后的lintOptions 保证遇到错误会继续进行Gradle Build,也是我自己加上的,
然后如果还觉得不保险,在类名的前面加上@SuppressWarnings(“deprecation”)
这样一来GradleBuild可以Successful,也能顺利的将这个Demo运行在自己的手机上了。

展开阅读全文

没有更多推荐了,返回首页