HDU 4864 Task(贪心)

Task

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4830    Accepted Submission(s): 1262


Problem Description
Today the company has m tasks to complete. The ith task need xi minutes to complete. Meanwhile, this task has a difficulty level yi. The machine whose level below this task’s level yi cannot complete this task. If the company completes this task, they will get (500*xi+2*yi) dollars.
The company has n machines. Each machine has a maximum working time and a level. If the time for the task is more than the maximum working time of the machine, the machine can not complete this task. Each machine can only complete a task one day. Each task can only be completed by one machine.
The company hopes to maximize the number of the tasks which they can complete today. If there are multiple solutions, they hopes to make the money maximum.
 

Input
The input contains several test cases. 
The first line contains two integers N and M. N is the number of the machines.M is the number of tasks(1 < =N <= 100000,1<=M<=100000).
The following N lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the maximum time the machine can work.yi is the level of the machine.
The following M lines each contains two integers xi(0<xi<1440),yi(0=<yi<=100).xi is the time we need to complete the task.yi is the level of the task.
 

Output
For each test case, output two integers, the maximum number of the tasks which the company can complete today and the money they will get.
 

Sample Input
  
  
1 2 100 3 100 2 100 1
 

Sample Output
  
  
1 50004
 

题目分析:读懂题意之后就知道是用贪心做的,对机器和任务的x都进行降序排序,然后再根据任务的y和机器的y一一比较,需要注意的是最大利益,那么任务的y要取满足条件的机器的y的最小值。
看代码可以领会一下,这道题应该是挺难想的。
#include <stdio.h>
#include <algorithm>
using namespace std;

struct node1
{
	int x;
	int y;
}n1[100005],n2[100005];

int cmp(node1 a,node1 b)
{
	if(a.x != b.x)
	   return a.x > b.x;
	else
		return a.y > b.y;
}


void main()
{
    int i,j,k;
    int n,m;
	int cnt ;
	__int64 sum ;
	
	while(~scanf("%d%d",&n,&m))
	{
		
		for(i=0;i<n;i++)
		{
			scanf("%d%d",&n1[i].x,&n1[i].y);
		}
		for(i=0;i<m;i++)
		{
			scanf("%d%d",&n2[i].x,&n2[i].y);
		}
		
		sort(n1,n1+n,cmp);
		sort(n2,n2+m,cmp);
		
		int c[105] = {0};
		cnt =sum =0;
		for(i=0,j=0;i<m;i++)
		{
			while(j<n && n1[j].x >= n2[i].x)
			{
				c[n1[j].y]++;
				j++;
			}

			for(k=n2[i].y;k<100;k++)
			{
				if(c[k])
				{
					c[k]--;
					cnt++;	
					sum +=(n2[i].x*500 + n2[i].y*2);
					break;
				}
			}
		}
		
		printf("%d %I64d\n",cnt,sum);  
	}

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值