关于安卓连接postgresql需要注意的问题

这两天一直在写一个安卓的购物app

用的是postgresql,我怀疑pg的驱动用在安卓下面有版本限制,所以尽量不要设置目标版本,设置最小版本为8,不会出现获取不到conn=null的情况

(1)提醒1

需要注意的是好像在androidmanifest,xml中不能设置targetsdkversion,且minsdkversion="8"才行

否则会出现conn=null的情况。

(2)提醒2

另外最好用postgresql-9.2-1003.jdbc4.jar这个驱动,我试过用9.3的提示找不到类

否则会出现CLASS NOT FOUND的情况

(3)提醒3

才外那些还在用adt16的童鞋们,升级adt之后

在引用外部jar的时候虽然引用了jar包但是仍然可能会出现class not found 的错误提示的时候

最好还是右击项目->android tools->fix project properties修复一下

然后再右击项目->build path->configure build path->java build path->order and export,钩上你需要一起编译进apk的jar包,否则运行的时候又会出现找不到类了。

就这么多,希望遇到这些问题的童鞋不要这么虐心了

特别是用pg数据库的时候,这问题不是一般地虐心。


给个下载连接,方便各位同志

http://download.csdn.net/detail/xizero00/6785875

©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页