poj1013(称量+hash)

Counterfeit Dollar
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 36388 Accepted: 11624

Description

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins.
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively.
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.

Input

The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A--L. Information on a weighing will be given by two strings of letters and then one of the words ``up'', ``down'', or ``even''. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

Output

For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

Sample Input

1 
ABCD EFGH even 
ABCI EFJK up 
ABIJ EFGH even 

Sample Output

K is the counterfeit coin and it is light. 

Source

本题是个称量问题。由于题目说每个物品只有一个,且是在秤上称量的。若某一边轻,则有可能含个轻的,那边的字符对应的hash表减1;若某边重,则可能含个重的,那边的字符对应的hash表加1。轻的或重的物品那边肯定减或加的最多。
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;

int main()
{
	int cas,i,j,len;
	cin>>cas;
	char str1[20],str2[20],str3[10],ch;
	int flag[12];
	while(cas--)
	{
		for(i=0;i<12;i++)
			flag[i]=20;
		
		for(i=0;i<3;i++)
		{
			scanf("%s%s%s",str1,str2,str3);
			if(!strcmp(str3,"even"))//排除一些
			{
				len=strlen(str1);
				for(j=0;j<len;j++)
					flag[str1[j]-'A']=0;
				len=strlen(str2);
				for(j=0;j<len;j++)
					flag[str2[j]-'A']=0;
			}
			else if(!strcmp(str3,"up"))//排除一些
			{
				len=strlen(str1);
				for(j=0;j<len;j++)
					if(flag[str1[j]-'A']!=0)
						flag[str1[j]-'A']++;
					len=strlen(str2);
					for(j=0;j<len;j++)
						if(flag[str2[j]-'A']!=0)
							flag[str2[j]-'A']--;
			}
			else if(!strcmp(str3,"down"))//排除一些
			{
				len=strlen(str1);
				for(j=0;j<len;j++)
					if(flag[str1[j]-'A']!=0)
						flag[str1[j]-'A']--;
					len=strlen(str2);
					for(j=0;j<len;j++)
						if(flag[str2[j]-'A']!=0)
							flag[str2[j]-'A']++;
			}
		}
		int ans=-1;
		for(i=0;i<12;i++)
		{
			//cout<<flag[i]<<"  ";
			if(flag[i]!=0&&ans<abs(flag[i]-20))
			{
			//cout<<"*******"<<endl;
				ans=abs(flag[i]-20);
				ch='A'+i;
			}
		}
		if(flag[ch-'A']<20)
			printf("%c is the counterfeit coin and it is light.\n",ch);
			// 	printf("%c is the counterfeit coin and it is light.\n",ch); 
		else 
			printf("%c is the counterfeit coin and it is heavy.\n",ch);
	//	printf("%c is the counterfeit coin and it is heavy.\n",ch); 
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
YOLO高分设计资源源码,详情请查看资源内容中使用说明 YOLO高分设计资源源码,详情请查看资源内容中使用说明 YOLO高分设计资源源码,详情请查看资源内容中使用说明 YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明YOLO高分设计资源源码,详情请查看资源内容中使用说明

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值