2011 Alibaba Programming Contest_1001_Coin Game

Coin Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1872    Accepted Submission(s): 498


Problem Description
After hh has learned how to play Nim game, he begins to try another coin game which seems much easier.
The game goes like this:
Two players start the game with a circle of n coins.
They take coins from the circle in turn and every time they could take 1~K continuous coins.
(imagining that ten coins numbered from 1 to 10 and K equal to 3, since 1 and 10 are continuous, you could take away the continuous 10 , 1 , 2 , but if 2 was taken away, you couldn't take 1, 3, 4, because 1 and 3 aren't continuous)
The player who takes the last coin wins the game.
Suppose that those two players always take the best moves and never make mistakes.
Your job is to find out who will definitely win the game.
 

Input
The first line is a number T(1<=T<=100), represents the number of case. The next T blocks follow each indicates a case.
Each case contains two integers N,K(3<=N<=109,1<=K<=10).
 

Output
For each case, output the number of case and the winner "first" or "second".(as shown in the sample output)
 

Sample Input
  
  
2 3 1 3 2
 

Sample Output
  
  
Case 1: first Case 2: second
 

Author
NotOnlySuccess




取石子问题的变形,只是把一堆石子变成一圈石子。

按照题意,是后手容易赢。为什么捏?呃,只是直觉而已。。所以要先证明一下这个直觉:先手第一次拿了之后,就把一个圈变成了一条链,然后后手在中间点拿了之后,变成两条一样的链,之后,无论先手在哪里拿,后手都在对称的地方拿,这样的话,只要先手有得拿,后手就有得拿,所以最后那个就是后手拿的。

当然,还有例外的情况,比如,k=1的时候,如果n是奇数,那么就是先手赢;还有一种情况,那就是当k>=n的时候,先手第一次就把所有的石子都拿光了。


代码:

#include <iostream>

using namespace std;



typedef long long ll;



int main()

{

    int t;

    ll n, m;

    cin >> t;

    for (int k = 1; k <= t; k++)

    {

        cin >> n >> m;

        if (m >= n || (m == 1 && n % 2 != 0))

        {

            cout << "Case " << k << ": first" << endl;

            continue;

        }

        else cout << "Case " << k << ": second" << endl;

    }

}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值