1024. Palindromic Number (25)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:
67 3
Sample Output 1:
484
2
Sample Input 2:
69 3
Sample Output 2:
1353
3

提交代

——————————

long long 类型的最大为19位,而反序相加的话,最大可达10^40,不行。

#include <iostream>
#include <cstring>

using namespace std;

/* run this program using the console pauser or add your own getch, system("pause") or input loop */

bool isPalindromic(long long int n){
	int c[20];
	int i=0;
	while(n>0){
		c[i++]=n%10;
		n/=10;
	}
	for(int j=0; j<i/2; j++){
		if(c[j] != c[i-j-1])	return false;
	}
	return true;
}
long long int Palindromic(long long int n){
	long long int res=0;
	while(n>0){
		res=res*10+n%10;
		n/=10;
	}
	return res;
}

int main(int argc, char** argv) {
	long long int N,K;
	scanf("%lld %lld",&N,&K);
	
	long long int tmp=N;
	bool flag=false;
	for(int i=0; i<K; i++){
		if(isPalindromic(tmp)){
			cout<<tmp<<endl<<i<<endl;
			flag=true;
			break;
		}else{
			tmp+=Palindromic(tmp);
		}
	}
	if(!flag) cout<<tmp<<endl<<K<<endl;
	
	return 0;
}


————————————————————————

所以用string进行操作。

注意string的操作,可以直接使用reverse函数,和string.size().



#include <iostream>
#include <cstring>
#include <vector>
#include <algorithm>

using namespace std;

/* run this program using the console pauser or add your own getch, system("pause") or input loop */

bool isPalindromic(string n){
	string res=n;
	
	reverse(n.begin(),n.end());
	if(res==n)	return true;
	return false;
}
string addPalindromic(string a){
	string res,rever=a;
	int carry=0,sum=0;
	
	reverse(rever.begin(),rever.end());
	for(int i=0; i<rever.size(); i++){
		sum=a[i]-'0'+rever[i]-'0'+carry;
		carry=sum/10;
		res.insert(res.begin(),sum%10+'0');
	}
	if(carry) res.insert(res.begin(),carry+'0');
	
	return res;
}

int main(int argc, char** argv) {
	string N;
	int K;
	
	cin>>N;
	scanf("%d",&K);
	
	string tmp=N;
	bool flag=false;
	for(int i=0; i<K; i++){
		if(isPalindromic(tmp)){
			cout<<tmp<<endl<<i<<endl;
			flag=true;
			break;
		}else{
			tmp=addPalindromic(tmp);
		}
	}
	if(!flag) cout<<tmp<<endl<<K<<endl;
	
	return 0;
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值