[翻译] LaTeX Error: Can be used only in preamble

原  文:LaTeX Error: Can be used only in preamble
译  者:Xovee
翻译时间:2020年6月11日

LaTeX Error: Can be used only in preamble

如果你在正文中引入了某个包或者类,而不是在序言(preamble)中,那么就会发生这个错误。在命令 \begin{document} 之前的内容,都被称为序言。在序言中,你定义文档的类型,文档的语言,以及很多基础的设定。例如,一般文档的序言大致是下面这个样子:

\documentclass[12pt, letterpaper]{article}
\usepackage[utf8]{inputenc}
\usepackage{amsmath}

\title{First document}
\author{Hubert Farnsworth \thanks{funded by the ShareLaTeX team}}
\date{February 2014}

如果你在正文中引入了包(在 \begin{document} 之后),而不是在序言之中,那么就会遇到这个错误:

在这里插入图片描述

为了解决这个错误,你必须确保所有的包引入命令 \usepackage{…}、以及 \documentclass[]{…} 等,位于 \begin{document} 命令之前。如果你想了解更多的有关 LaTeX 文档结构的信息,请参考这篇文档。

展开阅读全文
©️2020 CSDN 皮肤主题: 终极编程指南 设计师: CSDN官方博客 返回首页
实付0元
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值