The Frog's Games (二分)

The Frog’s Games

Time limit:1000 ms Memory limit:65768 kB


Problem Description

The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).

Input

The input contains several cases. The first line of each case contains three positive integer L, n, and m. 
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.

Output

For each case, output a integer standing for the frog's ability at least they should have.

Sample Input

6 1 2
2
25 3 3
11 
2
18

Sample Output

4
11

题意:

河的宽度:L
青蛙在河上的n个上石头跳
最多跳m次
如果要过河,每次次最少需要跳多远(每次跳的距离一样)

解题思路:

直接二分,最小化最大值,每次选择石头的时候选择最远的能跳到的石头

Code:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;

const int maxn=500000+5;
int a[maxn];
int L,n,m;

bool f(int x)
{
    int pos=0,cnt=0;
    a[n+1]=L,a[n+2]=3*L;
    for(int i=0;i<=n+1;)
    {
        if(a[i+1]-pos>x)
            return false;
        while(a[i+1]-pos<=x&&i<=n+1)
            i++;
        pos=a[i];
        cnt++;
        if(cnt>m)
            return false;
        if(i==n+1)
            return true;
    }
    return true;
}

int bs()
{
    int lo=0,hi=L,mid;
    int ans=hi;
    while(lo<=hi)
    {
        mid=((hi-lo)>>1)+lo;
        if(f(mid))
        {
            hi=mid-1;
            ans=min(ans,mid);
        }

        else
            lo=mid+1;
    }
    return ans;
}

int main()
{

    while(scanf("%d%d%d",&L,&n,&m)!=EOF)
    {
        memset(a,0,sizeof(a));
        a[0]=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        sort(a,a+n+1);
        printf("%d\n",bs());
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值