Balanced Lineup - POJ 3264 - 线段树

140 篇文章 0 订阅

Balanced Lineup - POJ 3264 - 线段树

  For the daily milking, Farmer John’s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

  Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

  Line 1: Two space-separated integers, N and Q.
  Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i
  Lines N+2.. N+ Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

  Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

  题意:给你n个数和q个询问,每个询问包含两个整数a b,让你输出区间[a,b]上最大值和最小值的差值。

  思路:很简单,直接线段树区间查询就可以。还有一种方法是RMQ算法,看了一下博客感觉一知半解,先码一下等线段树专题写完了再回来看看这个写法。

  别人家的RMQ算法讲解传送门:RMQ (Range Minimum/Maximum Query)算法

AC代码:

//
//  main.cpp
//  L
//
//  Created by LucienShui on 2017/5/28.
//  Copyright © 2017年 LucienShui. All rights reserved.
//

#include <iostream>
#include <algorithm>
#include <set>
#include <string>
#include <vector>
#include <queue>
#include <map>
#include <iomanip>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cctype>
#define memset(a,b) memset(a,b,sizeof(a))
#define il inline
#define ll long long
#define ull unsigned long long

using namespace std;

#define ls (u<<1)
#define rs (u<<1|1)
#define lson u<<1,l,mid
#define rson u<<1|1,mid+1,r

const int maxn = 50000+7;
struct {
    int big,small;
}node[maxn<<2];

void build(int u, int l, int r) {
    if(l==r) {
        scanf("%d",&node[u].big);
        node[u].small = node[u].big;
        return ;
    }
    int mid = (l+r)>>1;
    build(lson);
    build(rson);
    node[u].big = max(node[ls].big,node[rs].big);
    node[u].small = min(node[ls].small,node[rs].small);
}

int querybig(int u, int l, int r, int b, int e) {
    if(b <= l && r <= e) {
        return node[u].big;
    }
    int mid = (l+r)>>1;
    if(e <= mid) return querybig(lson,b,e);
    else if (b > mid) return querybig(rson,b,e);
    else {
        return max(querybig(lson,b,e),querybig(rson,b,e));
    }
}

int querysmall(int u, int l, int r, int b, int e) {
    if(b <= l && r <= e) {
        return node[u].small;
    }
    int mid = (l+r)>>1;
    if(e <= mid) return querysmall(lson,b,e);
    else if (b > mid) return querysmall(rson,b,e);
    else {
        return min(querysmall(lson,b,e),querysmall(rson,b,e));
    }
}

int main ()
{
#ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
#endif // ONLINE_JUDGE
    int n,q;
    while(~scanf("%d%d",&n,&q)) {
        build(1,1,n);
        for(int i=0,a,b ; i<q ; i++) {
            scanf("%d%d",&a,&b);
            printf("%d\n",querybig(1,1,n,a,b)-querysmall(1,1,n,a,b));
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值