完美解决:IntelliJ IDEA中报错:Error: java: 无效的目标发行版本

问题描述

根据昨天在各种设置的时候,发现先后出现了:无效的目标发行版本5,和无效的目标发行版本11的错误,
经检查,都是和IDEA的maven设置有关,第一次出现错误的时候,查看IDEA默认使用的编译版本是11,但是实际使用的并不是。所以逐步检查设置

操作环境
IntelliJ IDEA 2019
本机JDK版本:1.8.0_241

报错详情如图
在这里插入图片描述

解决办法

首先在项目pom.xml中查看使用的版本:我这里使用的是1.8(即8版本)

  1. 菜单栏中File→Settings:
    在这里插入图片描述
    检查如图所示的位置,是否为正确的版本,不是的话改过来:
    在这里插入图片描述
    再检查这个位置
    在这里插入图片描述
  2. File→Project Structure:
    在这里插入图片描述
    在这里检查版本,是否都是8版本,我这里的情况是IDEA默认的Project SDK是11版本,其他都是乱的,这里手动改成我的1.8版本:
    在这里插入图片描述
    紧接着检查Modules里的版本是不是8在这里插入图片描述
    检查SDKs
    在这里插入图片描述
<ul style="color:rgba(0,0,0,.560784);font-size:14px;background-color:#FFFFFF;"> <li> <span>Tensorflow2.0介绍:</span> </li> </ul> <p style="color:rgba(0,0,0,.560784);font-size:14px;background-color:#FFFFFF;"> tensorflow是GOOGLE在2015年底发布的一款深度学习框架,也是目前全世界用得最多,发展最好的深度学习框架。2019年3月8日,GOOGLE发布最新tensorflow2版本。新版本的tensorflow有很多新特征,更快更容易使用更人性化。但是老版的tensorflow程序在新版本中几乎都无法继续使用,所以我们有必要学习新版tensorflow2的新用法。 </p> <ul style="color:rgba(0,0,0,.560784);font-size:14px;background-color:#FFFFFF;"> <li> <span>课程介绍:</span> </li> </ul> <p style="color:rgba(0,0,0,.560784);font-size:14px;background-color:#FFFFFF;"> 我们的这门课程适合小白学习,也适合有基础的同学学习。课程会从0开始学习,从python环境安装,python入门,numpy,pandas,matplotlib使用,深度学习基础,一直讲到tensorflow基础,进阶,项目实战。不管你是0基础小白,想进入AI行业,还是有一定基础,想学习最新的tensorflow2的使用,都适合我们这门课程。 </p> <ul style="color:rgba(0,0,0,.560784);font-size:14px;background-color:#FFFFFF;"> <li> <span>讲师介绍:</span> </li> </ul> <p style="color:rgba(0,0,0,.560784);font-size:14px;background-color:#FFFFFF;"> 覃秉丰,物理系毕业转AI行业,想转行同学可以找我聊聊。机器学习、深度学习神经网络领域多年研究开发授课经验,精通算法原理与编程实践;曾完成过多项图像识别、目标识别、语音识别等企业项目,一线实战经验丰富;长期为多家包括世界五百强在内的大型企业总部做人工智能技术内训服务(中国移动、中国银行,华夏银行,中国太平洋,国家电网、中海油等)。上课特点:公式尽量一个一个符号推,代码尽量一行一行讲,希望所有人都能学有所得。 </p>
相关推荐
©️2020 CSDN 皮肤主题: 游动-白 设计师:白松林 返回首页