POJ 1276 Cash Machine

126 篇文章 2 订阅

先说一下题意:给你两个数cash和N。cash代表你最多会换得多少钱,N代表有n种钱,然后输出n组数据,每组数据有两个数分别代表钱的数目与面值。最后输出最大的可以换得的<=cash的钱的价值。

典型的多重背包,但是悲催的是竟然各种超时,各种超内存啊、、我的算法有问题,每次枚举的时候都会造成重复。。。后来看了我师傅写的,加了一个计数就OK了啊、、、

Cash Machine
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 24249 Accepted: 8486

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <stdlib.h>
#include <cmath>

using namespace std;

int dp[1000000], cnt [1000000], f[100], p[100];
int main()
{
    int i, j, n, m;
    while(~scanf("%d %d",&m, &n))
    {
        memset(dp , 0 , sizeof(dp));
        for(i = 1; i <= n; i++)
            scanf("%d %d",&f[i], &p[i]);
        dp[0] = 1;
        for(i = 1; i <= n; i++)
        {
            memset(cnt , 0 , sizeof(cnt));
            for(j = p[i]; j <= m; j++)
            {
                if(!dp[j] && dp[j-p[i]] && cnt[j-p[i]] < f[i])
                {
                    dp[j] = 1;
                    cnt[j] = cnt[j-p[i]]+1;
                }
            }
        }
        for(i = m; i >= 0; i--)
            if(dp[i])
            {
                printf("%d\n",i);
                break;
            }
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值