POJ 3292 Semi-prime H-numbers(打表)

题意大体是:规定如果一个数是由1,5,9,13,17,21、、、这么一个等差数列中的任意两项组成的乘积组成的数称之为H-numbers。然后给你一个数输出比这个数字小的H-numbers有多少个、、、(貌似不能是乘1)。

类似的一个打表,数据范围也不广,可以水过啊、、、

Semi-prime H-numbers
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6888 Accepted: 2943

Description

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,... are the H-numbers. For this problem we pretend that these are theonly numbers. The H-numbers are closed under multiplication.

As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it's the product of three H-primes.

Input

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

Output

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

Sample Input

21 
85
789
0

Sample Output

21 0
85 5
789 62
#include <stdio.h>
#include <string.h>
#include <cmath>
#include <iostream>
#include <stdlib.h>
#include <map>

using namespace std;

int f[1001000];

void _printf()
{
    int i, j;
    memset(f , 0 , sizeof(f));
    for(i = 5; i <= 1000; i+= 4)
    {
        if(f[i] == 0)
        {
            for(j = i; i*j < 1000002; j+=4)
            {
                f[i*j] = f[i]+f[j]+1;
            }
        }
    }
    for(i = 25; i < 1000002; i++)
    {
        if(f[i] == 1)
            f[i] = f[i-1]+1;
        else
            f[i] = f[i-1];
    }
}

int main()
{
    int n;
    _printf();
    while(cin >>n)
    {
        if(!n)
            break;
        cout <<n<<' '<<f[n]<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值