HDU 1160 FatMouse's Speed(求最长递减序列+记录路径)

126 篇文章 2 订阅

这道题的意思是:有人认为老鼠越胖跑得越快。现在给你n个老鼠,给出每个老鼠的重量和速度。按重量排序后求出来有多少老鼠的的速度是一个递减序列。看看是否那个人是否正确。

输出序列的长度,还得输出这个序列上老鼠原来在输入时的位置。所以要用一个数组保存前驱。

注意:Special Judge

FatMouse's Speed

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8093    Accepted Submission(s): 3593
Special Judge


Problem Description
FatMouse believes that the fatter a mouse is, the faster it runs. To disprove this, you want to take the data on a collection of mice and put as large a subset of this data as possible into a sequence so that the weights are increasing, but the speeds are decreasing.
 

Input
Input contains data for a bunch of mice, one mouse per line, terminated by end of file.

The data for a particular mouse will consist of a pair of integers: the first representing its size in grams and the second representing its speed in centimeters per second. Both integers are between 1 and 10000. The data in each test case will contain information for at most 1000 mice.

Two mice may have the same weight, the same speed, or even the same weight and speed. 
 

Output
Your program should output a sequence of lines of data; the first line should contain a number n; the remaining n lines should each contain a single positive integer (each one representing a mouse). If these n integers are m[1], m[2],..., m[n] then it must be the case that 

W[m[1]] < W[m[2]] < ... < W[m[n]]

and 

S[m[1]] > S[m[2]] > ... > S[m[n]]

In order for the answer to be correct, n should be as large as possible.
All inequalities are strict: weights must be strictly increasing, and speeds must be strictly decreasing. There may be many correct outputs for a given input, your program only needs to find one. 
 

Sample Input
  
  
6008 1300 6000 2100 500 2000 1000 4000 1100 3000 6000 2000 8000 1400 6000 1200 2000 1900
 

Sample Output
  
  
4 4 5 9 7
 

#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-7
#define M 10001000
#define LL __int64
//#define LL long long
#define INF 0x3f3f3f3f
#define PI 3.1415926535898
const int maxn = 50000;

using namespace std;

struct node
{
    int w, s;
    int i;
} f[maxn];

int dp[maxn];
int pre[maxn];
int num[maxn];

int cmp(node a, node b)
{
    if(a.w == b.w)
        return a.s > b.s;
    return a.w < b.w;
}

int main()
{
    int n = 0;
    while(cin >>f[n].w>>f[n].s)
    {
        f[n].i = n+1;
        n++;
    }
    sort(f, f+n, cmp);
    for(int i = 0; i < n; i++)
    {
        pre[i] = -1;
        dp[i] = 1;
        for(int j = i-1; j >= 0; j--)
        {
            if(f[j].s > f[i].s && dp[i] < dp[j]+1)
            {
                dp[i] = dp[j]+1;
                pre[i] = j;
            }
        }
    }
    int m = 0;
    for(int i = 0; i < n; i++)
        if(dp[i] > dp[m])
            m = i;
    cout<<dp[m]<<endl;
    int t = 0;
    while(pre[m] != -1)
    {
        num[t++] = f[m].i;
        m = pre[m];
    }
    num[t++] = f[m].i;
    for(int i = t-1; i >= 0; i--)
        cout<<num[i]<<endl;
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值