POJ 3254 Corn Fields(简单的状态压缩dp)

126 篇文章 2 订阅
46 篇文章 0 订阅

这是第一次写状态压缩。

题目描述:给你n*m的一个草地,放牛。牛不能相邻。并且值为0的地方不能放牛。问一共有多少种方案,可以放牛。

不放也算一种。

Corn Fields
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6143 Accepted: 3259

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-7
#define M 1000100
//#define LL __int64
#define LL long long
#define INF 0x3f3f3f3f
#define PI 3.1415926535898

const int maxn = 10010;
using namespace std;

int mp[100][100];
int dp[15][1<<13];


LL Mod = 100000000;
int main()
{
    int n, m;
    while(cin >>n>>m)
    {
        memset(dp, 0, sizeof(dp));
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= m; j++)
                cin >>mp[i][j];
        for(int i = 0; i <= (1<<m); i++) dp[1][i] = 1;
        for(int i = 1; i < n; i++)
        {
            for(int j = 0; j < (1<<m); j++)
            {
                int cnt = 0;
                int k;
                for(k = 1; k <= m; k++)//在行中找满足条件的
                {
                    if(!mp[i][k] && (j&(1<<(k-1))))
                        break;
                    if(j&(1<<(k-1)))
                        cnt++;
                    else
                        cnt = 0;
                    if(cnt >= 2)
                        break;
                }
                if(k <= m) continue;
                for(k = 0; k < (1<<m); k++)//在列中找满足条件的
                {
                    int l;
                    for(l = 0; l < m; l++)
                        if((j&(1<<l)) && (k&(1<<l)))
                            break;
                    if(l < m) continue;
                    dp[i+1][k] += dp[i][j];
                }
            }
        }
        LL ans = 0;
        for(int i = 0; i < (1<<m); i++)
        {
            int cnt = 0;
            int k;
            for(k = 1; k <= m; k++)
            {
                if(!mp[n][k] && (i&(1<<(k-1))))
                    break;
                if(i&(1<<(k-1)))
                    cnt++;
                else
                    cnt = 0;
                if(cnt >= 2)
                    break;
            }
            if(k <= m) continue;
            ans += dp[n][i];
            ans %= Mod;
        }
        cout<<ans<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值