FZU Problem 2140 Forever 0.5

竟然是一个找规律,推出图形后直接在上面加一些点。真是长知识了啊。

注意:是有n条边满足长度为1。

一定要先做出来那个一个点在圆心其他三个点在正规圆的四边形出来,然后其他的点在两个点之间插就行了啊。

 Problem 2140 Forever 0.5

Accept: 38    Submit: 117    Special Judge
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

Given an integer N, your task is to judge whether there exist N points in the plane such that satisfy the following conditions:

1. The distance between any two points is no greater than 1.0.

2. The distance between any point and the origin (0,0) is no greater than 1.0.

3. There are exactly N pairs of the points that their distance is exactly 1.0.

4. The area of the convex hull constituted by these N points is no less than 0.5.

5. The area of the convex hull constituted by these N points is no greater than 0.75.

 Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each contains an integer N described above.

1 <= T <= 100, 1 <= N <= 100

 Output

For each case, output “Yes” if this kind of set of points exists, then output N lines described these N points with its coordinate. Make true that each coordinate of your output should be a real number with AT MOST 6 digits after decimal point.

Your answer will be accepted if your absolute error for each number is no more than 10-4.

Otherwise just output “No”.

See the sample input and output for more details.

 Sample Input

3
2
3
5

 Sample Output

No
No
Yes
0.000000 0.525731
-0.500000 0.162460
-0.309017 -0.425325
0.309017 -0.425325
0.500000 0.162460
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-8
#define M 1000100
//#define LL __int64
#define LL long long
#define INF 0x3f3f3f3f
#define PI 3.1415926535898

using namespace std;

const int maxn = 110;
struct node
{
    double x, y;
}f[maxn];

int main()
{
    f[0].x = 0.0;
    f[0].y = 0.0;
    f[1].x = 0.0;
    f[1].y = 1.0;
    f[2].x = 0.5;
    f[2].y = sqrt(3.0)/2;
    f[3].x = sqrt(3.0)/2;
    f[3].y = 0.5;
    for(int i = 4; i <= 101; i++)
    {
        f[i].x = f[2].x+i*0.0001;
        f[i].y = sqrt(1-(f[i].x)*(f[i].x));
    }

    int T;
    cin >>T;
    while(T--)
    {
        int n;
        cin >>n;
        if(n <= 3)
            cout<<"No"<<endl;
        else
        {
            cout<<"Yes"<<endl;
            for(int i = 0; i < n; i++)
               printf("%.6lf %.6lf\n",f[i].x, f[i].y);
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值