POJ 2193 Lenny's Lucky Lotto Lists(简单二维dp)

126 篇文章 2 订阅

一道水题,竟然脑子抽筋比赛时没做出来啊。sad、、、以位数和结尾数字进行dp。

Lenny's Lucky Lotto Lists
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2068 Accepted: 881

Description

Lenny likes to play the game of lotto. In the lotto game, he picks a list of N unique numbers in the range from 1 to M. If his list matches the list of numbers that are drawn, he wins the big prize. 
Lenny has a scheme that he thinks is likely to be lucky. He likes to choose his list so that each number in it is at least twice as large as the one before it. So, for example, if N = 4 and M = 10, then the possible lucky lists Lenny could like are: 
1 2 4 8 
1 2 4 9 
1 2 4 10 
1 2 5 10

Thus Lenny has four lists from which to choose. 
Your job, given N and M, is to determine from how many lucky lists Lenny can choose. 

Input

There will be multiple cases to consider from input. The first input will be a number C (0 < C <= 50) indicating how many cases with which you will deal. Following this number will be pairs of integers giving values for N and M, in that order. You are guaranteed that 1 <= N <= 10, 1 <= M <= 2000, and N <= M. Each N M pair will occur on a line of its own. N and M will be separated by a single space.

Output

For each case display a line containing the case number (starting with 1 and increasing sequentially), the input values for N and M, and the number of lucky lists meeting Lenny's requirements. The desired format is illustrated in the sample shown below.

Sample Input

3
4 10
2 20
2 200

Sample Output

Case 1: n = 4, m = 10, # lists = 4
Case 2: n = 2, m = 20, # lists = 100
Case 3: n = 2, m = 200, # lists = 10000
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-7
#define M 1000100
//#define LL __int64
#define LL long long
#define INF 0x3fffffff
#define PI 3.1415926535898
#define MOD 1000000007

using namespace std;

const int maxn = 2020;

LL dp[12][maxn];
int main()
{
    int T;
    cin >>T;
    for(int t = 1; t <= T; t++)
    {
        int n, m;
        cin >>n>>m;
        memset(dp, 0 , sizeof(dp));
        for(int i = 0; i <= m; i++)
            dp[1][i] = 1;
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= m; j++)
                for(int k = j+1; k <= m; k++)
                    if(k >= 2*j)
                        dp[i][k] += dp[i-1][j];
        LL sum = 0;
        for(int i = 1 ;i <= m; i++)
            sum += dp[n][i];
        cout<<"Case "<<t<<": n = "<<n<<", m = "<<m<<", # lists = "<<sum<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值