POJ 3107 Godfather(树形dp)

126 篇文章 2 订阅

题意是找大哥,是大哥的条件是:删除这个节点之后最大联通的点最少。

第一遍dfs找到每个节点有多少子节点,第二遍dfs求出删掉每个环节点之后会剩余多少个联通的节点,并求出最大联通节点的个数。

Godfather
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 4544 Accepted: 1539

Description

Last years Chicago was full of gangster fights and strange murders. The chief of the police got really tired of all these crimes, and decided to arrest the mafia leaders.

Unfortunately, the structure of Chicago mafia is rather complicated. There are n persons known to be related to mafia. The police have traced their activity for some time, and know that some of them are communicating with each other. Based on the data collected, the chief of the police suggests that the mafia hierarchy can be represented as a tree. The head of the mafia, Godfather, is the root of the tree, and if some person is represented by a node in the tree, its direct subordinates are represented by the children of that node. For the purpose of conspiracy the gangsters only communicate with their direct subordinates and their direct master.

Unfortunately, though the police know gangsters’ communications, they do not know who is a master in any pair of communicating persons. Thus they only have an undirected tree of communications, and do not know who Godfather is.

Based on the idea that Godfather wants to have the most possible control over mafia, the chief of the police has made a suggestion that Godfather is such a person that after deleting it from the communications tree the size of the largest remaining connected component is as small as possible. Help the police to find all potential Godfathers and they will arrest them.

Input

The first line of the input file contains n — the number of persons suspected to belong to mafia (2 ≤ n ≤ 50 000). Let them be numbered from 1 to n.

The following n − 1 lines contain two integer numbers each. The pair aibi means that the gangster ai has communicated with the gangster bi. It is guaranteed that the gangsters’ communications form a tree.

Output

Print the numbers of all persons that are suspected to be Godfather. The numbers must be printed in the increasing order, separated by spaces.

Sample Input

6
1 2
2 3
2 5
3 4
3 6

Sample Output

2 3
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-8
#define M 1000100
//#define LL __int64
#define LL long long
#define INF 0x3f3f3f3f
#define PI 3.1415926535898

const int maxn = 50010;
using namespace std;

int head[maxn];
int t;
int Max;
int sum[maxn];
int p[maxn];
int n;
struct node
{
    int to;
    int next;
} f[2*maxn];

void init()
{
    t = 0;
    Max = INF;
    memset(head, -1, sizeof(head));
}

void add(int x, int y)
{
    f[t].to = y;
    f[t].next = head[x];
    head[x] = t++;

    f[t].to = x;
    f[t].next = head[y];
    head[y] = t++;
}

void dfs1(int x, int fa)
{
    sum[x] = 1;
    for(int i = head[x]; i != -1; i = f[i].next)
    {
        int v = f[i].to;
        if(v == fa)
            continue;
        dfs1(v, x);
        sum[x] += sum[v];
    }
}

void dfs2(int x, int fa)
{
    int &ans = p[x] = n-sum[x];
    for(int i = head[x]; i != -1; i = f[i].next)
    {
        int v = f[i].to;
        if(v == fa)
            continue;
        dfs2(v, x);
        ans = max(ans, sum[v]);
    }
    Max = min(Max, ans);
}

int main()
{
    while(~scanf("%d",&n))
    {
        int u, v;
        init();
        for(int i = 0; i < n-1; i++)
        {
            scanf("%d %d",&u, &v);
            add(u,v);
        }
        dfs1(1, -1);
        dfs2(1, -1);
        int flag = 0;
        for(int i = 1; i <= n; i++)
        {
            if(p[i] == Max)
            {
                if(!flag)
                {
                    flag = 1;
                    printf("%d",i);
                }
                else
                    printf(" %d",i);
            }
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值