ZOJ Consecutive Blocks(左右指针移动)

题意很简单就是让你看看隔着k个不同的,最多还能构成多少个连续的啊。

10^5托托的不能o(n^2),显然是左右指针瞎搞啊,但是这道题可以排序使得更简单。

按照数字的大小,和地址的先后二级排序,然后分相同数字和不相同数字进行讨论,找到满足条件的最优的解。

Consecutive Blocks

Time Limit: 2 Seconds       Memory Limit: 65536 KB

There are N (1 ≤ N ≤ 105) colored blocks (numbered 1 to N from left to right) which are lined up in a row. And the i-th block's color is Ci (1 ≤ Ci ≤ 109). Now you can remove at most K (0 ≤ K ≤N) blocks, then rearrange the blocks by their index from left to right. Please figure out the length of the largest consecutive blocks with the same color in the new blocks created by doing this.

For example, one sequence is {1 1 1 2 2 3 2 2} and K=1. We can remove the 6-th block, then we will get sequence {1 1 1 2 2 2 2}. The length of the largest consecutive blocks with the same color is 4.

Input

Input will consist of multiple test cases and each case will consist of two lines. For each test case the program has to read the integers N and K, separated by a blank, from the first line. The color of the blocks will be given in the second line of the test case, separated by a blank. The i-th integer means Ci.

Output

Please output the corresponding length of the largest consecutive blocks, one line for one case.

Sample Input
8 1
1 1 1 2 2 3 2 2
Sample Output
4
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-8
#define M 1000100
//#define LL __int64
#define LL long long
#define INF 0x7ffffff
#define PI 3.1415926535898


const int maxn = 101000;

using namespace std;

struct node
{
    int x;
    int point;
}f[maxn];

bool cmp(node a, node b)
{
    if(a.x == b.x)
        return a.point < b.point;
    return a.x < b.x;
}

int main()
{
    int n, k;
    while(cin >>n>>k)
    {
        int x;
        for(int i = 0; i < n; i++)
        {
            cin >>x;
            f[i].x = x;
            f[i].point = i;
        }
        sort(f, f+n, cmp);
        int Max = -1;
        int i, j;
        int r = 1;
        int dis = 1;
        for(i = 0; i < n;)
        {
            dis = r-i;
            for(j = r; j < n; j++)
            {
                if(f[i].x != f[j].x)
                {
                    Max = max(Max, dis);
                    i = j;
                    r = j+1;
                    break;
                }
                if(f[j].point-f[i].point > j-i+k)
                {
                    Max = max(Max, dis);
                    i++;
                    dis--;
                    r = j;
                    break;
                }
                dis++;
            }
            if(j == n)
            {
                Max = max(dis, Max);
                break;
            }
        }
        cout<<Max<<endl;
    }
    return 0;
}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值