HDU 4946 Area of Mushroom(凸包)

如果一个人能统治无穷远处,那么他的速度一定是最大的。除了那几种很坑的数据,比如同一个点速度相同的两个人。永远都是不可能。所以你要处理出来所有速度最大的点,然后用他们构成一个凸包,你把端点的点求出来了,还得判断一下在边上的情况。然后顶点和在边上的点所构成的就是可以到达无穷远处的人。

PS:抄了芳姐的模版。。哈哈哈

Area of Mushroom

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 676    Accepted Submission(s): 120


Problem Description
Teacher Mai has a kingdom with the infinite area.

He has n students guarding the kingdom.

The i-th student stands at the position (x i,y i), and his walking speed is v i.

If a point can be reached by a student, and the time this student walking to this point is  strictly less than other students, this point is in the charge of this student.

For every student, Teacher Mai wants to know if the area in the charge of him is infinite.
 

Input
There are multiple test cases, terminated by a line "0".

For each test case, the first line contains one integer n(1<=n<=500).

In following n lines, each line contains three integers x i,y i,v i(0<=|x i|,|y i|,v i<=10^4).
 

Output
For each case, output "Case #k: s", where k is the case number counting from 1, and s is a string consisting of n character. If the area in the charge of the i-th student isn't infinite, the i-th character is "0", else it's "1".
 

Sample Input
  
  
3 0 0 3 1 1 2 2 2 1 0
 

Sample Output
  
  
Case #1: 100
 

Source
 
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <ctime>
#include <map>
#include <set>
#define eps 1e-9
///#define M 1000100
#define LL __int64
///#define LL long long
///#define INF 0x7ffffff
#define INF 0x3f3f3f3f
#define PI 3.1415926535898
#define zero(x) ((fabs(x)<eps)?0:x)
#define clearall(A, X) memset(A, X, sizeof(A))

using namespace std;

const int maxn = 2010;

struct point
{
    int x,y;
    int v,id;
    point(int x = 0,int y = 0):x(x),y(y) {}
} p[maxn],ch[maxn],q[maxn],pq[maxn];
int f[maxn];
typedef point pointt;
point operator -(point a,point b)
{
    return point(a.x-b.x,a.y-b.y);
}
int dcmp(double x)
{
    if(fabs(x)<eps) return 0;
    return x<0?-1:1;
}
int cross(point a,point b)
{
    return a.x*b.y-a.y*b.x;
}
int mul(point a,point b,point c)
{
    return cross(b-a,c-a);
}
double dis(point a)
{
    return sqrt(a.x*a.x+a.y*a.y);
}
bool cmp(point a,point b)
{
    if(mul(p[0],a,b)==0)
        return dis(a-p[0])<dis(b-p[0]);
    return mul(p[0],a,b)>0;
}
int graham(int n)///返回点的个数
{
    int i,k =0 ,top;
    if(n<2) return 0;
    point tmp ;
    for(i = 0; i < n ; i++)
    {
        if(dcmp(p[i].y-p[k].y)<0||(dcmp(p[i].y-p[k].y)==0&&dcmp(p[i].x-p[k].x)<0))
            k = i;
    }
    swap(p[k],p[0]);
    sort(p+1,p+n,cmp);
    ch[0] = p[0];
    ch[1] = p[1];
    top = 1;
    for(i = 2; i < n ; i++)
    {
        while(top>0&&dcmp(mul(ch[top-1],ch[top],p[i]))<=0) top--;
        top++;
        ch[top] = p[i];
    }
    return top;
}
bool cmpp(point a,point b)
{
    if(a.x==b.x) return a.y<b.y;
    return a.x<b.x;
}

int main()
{
    int Case = 1;
    int n;
    while(cin >>n)
    {
        if(!n) break;
        memset(f, 0, sizeof(f));
        int Max = -INF;
        for(int i = 1; i <= n; i++)
        {
            scanf("%d %d %d",&q[i].x, &q[i].y, &q[i].v);
            q[i].id = i;
            if(!q[i].v) f[i] = -2;
            Max = max(Max, q[i].v);
        }
        for(int i = 1; i <= n; i++)
        {
            if(q[i].v != Max) continue;
            for(int j = i+1; j <= n; j++)
            {
                if(q[j].x == q[i].x && q[j].y == q[i].y && q[j].v == q[i].v)
                {
                    f[q[j].id] = -1;
                    f[q[i].id] = -1;
                }
            }
        }
        int t = 0;
        for(int i = 1; i <= n; i++)
            if(q[i].v == Max && f[q[i].id] != -2) p[t++] = q[i];
        int m = graham(t);
        cout<<"Case #"<<Case++<<": ";
        if(m < 2)
        {
            for(int i = 1; i <= n; i++)
            {
                if(f[i] != -1 && f[i] != -2 && q[i].v == Max) cout<<1;
                else cout<<0;
            }
            cout<<endl;
            continue;
        }
        ch[m+1] = ch[0];
        for(int i = 0; i <= m; i++) if(!f[ch[i].id]) f[ch[i].id] = 1;
        for(int i = 1; i <= n; i++)
        {
            if(f[i] || q[i].v != Max) continue;
            for(int j = 0; j <= m; j++)
                if(mul(ch[j], ch[j+1], q[i]) == 0) f[i] = 1;
        }
        for(int i = 1; i <= n; i++)
        {
            if(f[i] == 1) cout<<1;
            else cout<<0;
        }
        cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值