HDU OJ 1081 To The Max

126 篇文章 2 订阅
一开始做的时候没有思路,不知道该怎么做,感觉暴力肯定会超时的。。没敢做,后来看了题解感觉方法不错,就学习了。。。
参考博客  http://blog.csdn.net/acm_davidcn/article/details/5834454 感谢这位大神。
这题的意思就是找到子矩阵中最大的和值。
这是学习的解题思路:DP 求最大和子矩阵 , 可以用最大和连续子序列的思路解 .
首先 , 读数据的时候 a[i][j] 为前 i 行数据的第 j 个数的和 , 当求第 p 行到第 q 行之间宽为 p-q+1 的最大和矩阵的时候 , 就以 p 行和 q 行之间的同一列的数字的和作为一个数列的元素 , 然后 DP 求这个数列的最大和连续子序列 , 就是第 p 行到第 q 行之间宽为 p-q+1 的最大和矩阵 .
To The Max


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6060    Accepted Submission(s): 28

Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.


As an example, the maximal sub-rectangle of the array:


0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2


is in the lower left corner:


9 2
-4 1
-1 8


and has a sum of 15.
 


Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 


Output
Output the sum of the maximal sub-rectangle.
 


Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2
 


Sample Output
15
 
#include <stdio.h>
#include <string.h>
int main()
{
    int dp[105][105];
    int i, j, k, t, max, sum, n;
    while(~scanf("%d",&n))
    {
        memset(dp , 0 , sizeof(dp));
        for(i = 1; i <= n; i++)
            for(j = 1; j <= n; j++)
            {
                scanf("%d",&dp[i][j]);
                dp[i][j] += dp[i-1][j];
            }
        max =  0;
        for(i = 1; i <= n; i++)
        {
            for(j = i; j <= n; j++)
            {
                sum = 0;
                for(k = 1; k <= n; k++)
                {
                    t = dp[j][k] - dp[i-1][k];
                    sum+= t;
                    if(sum > max)
                    max = sum;
                    if(sum < 0)
                    sum = 0;
                }
            }
        }
        printf("%d\n",max);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值