SDUT OJ 2693 Babelfish (map练习)

11 篇文章 0 订阅
4 篇文章 0 订阅

这是一道典型的map但也可以用字典树与排序二叉树A、、、嘿嘿

题目描述

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.
 

输入

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

输出

  Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

示例输入

dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

示例输出

cat
eh
loops
#include <stdio.h>
#include <map>
#include <iostream>
#include <string>
#include <string.h>

using namespace std;

char s[101000][110];
int main()
{
    int i;
    char str[1100];
    map<string, int> mp;
    string name;
    for(i = 1; i <= 100000; i++)
    {
        cin >>s[i]>>name;
        mp[name] = i;
    }
    for(i = 1; i <= 100000; i++)
    {
        scanf("%s",str);
        if(mp[str] != 0)
            printf("%s\n",s[mp[str]]);
        else
            printf("eh\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值