POj 1094 Sorting It All Out

这是一道标准的topsort的题目,就是判环,还有就有条件不足几种情况,只要理清了思路还是比较好些的,一开始自己不会啊,就学习了ZP同学的代码、、自己敲了两遍感觉很好啊。。向鹏哥学习啊、、、还有就是注意判重边这是一个小习惯啊、、、

Sorting It All Out
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 24425 Accepted: 8451

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.
#include <stdio.h>
#include <string.h>
#include <iostream>
#define N 50

using namespace std;

int map[N][N], list[N], du[N], re[N];

int find(char * str , int n)
{
    int start = str[0]-'A';
    int end = str[2]-'A';
    if(map[start][end] == 0)
    {
        map[start][end] = 1;
        list[end] ++;
    }
    int i, t = 0, flat = 1, w, cnt;
    for(i = 0; i < n; i++)
        du[i] = list[i];
    for(int k = 0; k < n; k++)
    {
        cnt = 0;
        for(i = 0; i < n; i++)
            if(du[i] == 0)
            {
                cnt ++;
                w = i;
            }
        if(cnt == 0)
            return -1;
        else if(cnt > 1)
            flat = 0;
        du[w]--;
        re[t++] = w;
        for(i = 0; i < n; i++)
            if(map[w][i] == 1)
                du[i]--;
    }
    if(flat)
        return 1;
    else
        return 0;
}

void _printf(int n, int m)
{
    int i, j, t, flat = 1;
    char str[20030];
    memset(list , 0 , sizeof(list));
    memset(map , 0 , sizeof(map));
    for(i = 0; i < m; i++)
    {
        cin >>str;
        if(flat)
        {
            t = find(str,n);
            if(t == 1)
            {
                printf("Sorted sequence determined after %d relations: ",i+1);
                for(j = 0; j < n; j++)
                    printf("%c",re[j]+'A');
                printf(".\n");
                flat = 0;
            }
            else if(t == -1)
            {
                cout<<"Inconsistency found after "<<i+1<<" relations."<<endl;
                flat = 0;
            }
        }
    }
    if(flat)
        cout <<"Sorted sequence cannot be determined."<<endl;
}

int main()
{
    int n,m,i;
    char str[10000];
    while(cin>>n>>m)
    {
        if(n==0&&m==0)break;
        if(n-1>m)
        {
            for(i=0; i<m; i++)
            {
                cin>>str[i];
            }
            cout<<"Sorted sequence cannot be determined."<<endl;
        }
        else
        {
            _printf(n,m);
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值