【PAT (Advanced Level) Practice】1015 Reversible Primes (20 分)python题解

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<105) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line if YesN is a reversible prime with radix D, or if not.No

Sample Input:

73 10
23 2
23 10
结尾无空行

Sample Output:

Yes
Yes
No
结尾无空行
def change(x,d):#把十进制的x转换成d进制,并输出反转的d进制数的字符串
    num = ''
    while x:
        num += str(x % d)
        x //= d
    return num

def decideprime(x):#判断是否为素数
    if x == 0 or x == 1:
        return False
    for i in range(2,int(x**0.5)+1):
        if x % i == 0:
            return False
    return True

while 1:
    data = list(input().split())
    if int(data[0]) < 0:
        break
    else:
        a = int(data[0])
        b = int(data[1])
        k = change(a,b)
        length1 = len(k)-1
        S = 0
        for i in k:#把反转后的d进制数转换成十进制数
            S += int(i)*(b**length1)
            length1 -= 1
        if decideprime(a) and decideprime(S):
            print('Yes')
        else:
            print('No')
        

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值