【PAT (Advanced Level) Practice】1023 Have Fun with Numbers (20 分)python题解

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:

1234567899

结尾无空行

Sample Output:

Yes
2469135798

结尾无空行

N = input()
P = str(int(N)*2)
num1 = {}
num2 = {}
num1 = num1.fromkeys((0,1,2,3,4,5,6,7,8,9),0)
num2 = num2.fromkeys((0,1,2,3,4,5,6,7,8,9),0)
for i in N:
    num1[int(i)] += 1
for i in P:
    num2[int(i)] += 1
flag = 0
for i in range(10):
    if num1[i] != num2[i] and flag == 0:
        print('No')
        flag = 1
if flag == 0:
    print('Yes')
print(P)

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值