Count Color
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 34059 | Accepted: 10269 |
Description
Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.
There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board:
1. "C A B C" Color the board from segment A to segment B with color C.
2. "P A B" Output the number of different colors painted between segment A and segment B (including).
In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your.
There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board:
1. "C A B C" Color the board from segment A to segment B with color C.
2. "P A B" Output the number of different colors painted between segment A and segment B (including).
In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your.
Input
First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.
Output
Ouput results of the output operation in order, each line contains a number.
Sample Input
2 2 4 C 1 1 2 P 1 2 C 2 2 2 P 1 2
Sample Output
2 1
Source
注意两种更新和询问方式等价
#define DeBUG
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <vector>
#include <stack>
#include <queue>
#include <string>
#include <set>
#include <sstream>
#include <map>
#include <bitset>
using namespace std ;
#define zero {0}
#define INF 0x3f3f3f3f
#define EPS 1e-6
typedef long long LL;
const double PI = acos(-1.0);
//#pragma comment(linker, "/STACK:102400000,102400000")
inline int sgn(double x)
{
return fabs(x) < EPS ? 0 : (x < 0 ? -1 : 1);
}
#define N 100005
int COLOR[40] = {0, 1, 2, 4, 8, 16, 32, 64, 128, 256, 512, 1024, 2048, 4096, 8192, 16384, 32768, 65536, 131072, 262144
, 524288, 1048576, 2097152, 4194304, 8388608, 16777216, 33554432, 67108864, 134217728, 268435456, 536870912
};
struct Node
{
int l, r;
int mid;
int color;
bool cover;
};
Node tree[N * 4];
int getcolor(int n)
{
int sum = 0;
while (n)
{
if (n & 1)
sum++;
n >>= 1;
}
return sum;
}
void relax(int id)
{
if (tree[id].cover)
{
tree[id << 1].cover = tree[id << 1 | 1].cover = true;
tree[id << 1].color = tree[id << 1 | 1].color = tree[id].color;
tree[id].cover = false;
}
}
void build(int id, int l, int r)
{
Node &t = tree[id];
t.l = l;
t.r = r;
t.color = COLOR[1];
t.cover = false;
t.mid = (l + r) >> 1;
if (l == r)
return;
build(id << 1, l, t.mid);
build(id << 1 | 1, t.mid + 1, r);
}
void update(int id, int l, int r, int color)
{
Node &t = tree[id];
//1
if (l == t.l && r == t.r)
{
t.cover = true;
t.color = COLOR[color];
return;
}
//1
// if (l <= t.l && r >= t.r)
// {
// t.cover = true;
// t.color = COLOR[color];
// return;
// }
relax(id);
// if (t.mid >= l)
// update(id << 1, l, r, color);
// if (t.mid < r)
// update(id << 1 | 1, l, r, color);
//2
if (t.mid < l)
update(id << 1 | 1, l, r, color);
else if (t.mid >= r)
update(id << 1, l, r, color);
else
{
update(id << 1, l, t.mid, color);
update(id << 1 | 1, t.mid + 1, r, color);
}
//2
tree[id].color = tree[id << 1].color | tree[id << 1 | 1].color;
}
int query(int id, int l, int r)
{
Node &t = tree[id];
//1
if (t.l == l && t.r == r)
return t.color;
//1
// if (t.l >= l && t.r <= r)
// return t.color;
relax(id);
int sum1 = 0, sum2 = 0;
// if (t.mid >= l)
// sum1=query(id << 1, l, r);
// if (t.mid < r)
// sum2=query(id << 1 | 1, l, r);
// 2
if (t.mid < l)
sum1 = query(id << 1 | 1, l, r);
else if (t.mid >= r)
sum2 = query(id << 1, l, r);
else
{
sum1 = query(id << 1, l, t.mid);
sum2 = query(id << 1 | 1, t.mid + 1, r);
}
//2
return sum1 | sum2;
}
void update2(int id, int l, int r, int color)
{
Node &t = tree[id];
if (l <= t.l && t.r <= r)
{
t.cover = true;
t.color = COLOR[color];
return;
}
relax(id);
if (t.mid >= l)
update2(id << 1, l, r, color);
if (t.mid < r)
update2(id << 1 | 1, l, r, color);
tree[id].color = tree[id << 1].color | tree[id << 1 | 1].color;
}
int query2(int id, int l, int r)
{
Node &t = tree[id];
if (l <= t.l && t.r <= r)
return t.color;
relax(id);
int sum1 = 0, sum2 = 0;
if (t.mid >= l)
sum1 = query2(id << 1, l, r);
if (t.mid < r)
sum2 = query2(id << 1 | 1, l, r);
return sum1 | sum2;
}
int main()
{
#ifdef DeBUGs
freopen("C:\\Users\\Sky\\Desktop\\1.in", "r", stdin);
#endif
int L, T, O;
while (scanf("%d%d%d", &L, &T, &O) + 1)
{
char op[10];
int a, b, c;
build(1, 1, L);
for (int i = 1; i <= O; i++)
{
scanf("%s", op);
if (op[0] == 'C')
{
scanf("%d%d%d", &a, &b, &c);
update2(1, a, b, c);
}
else
{
scanf("%d%d", &a, &b);
if (a > b)
swap(a, b);
printf("%d\n", getcolor(query2(1, a, b)));
}
}
}
return 0;
}