【hdu1517】乘数博弈 dp求博弈

A Multiplication Game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3642    Accepted Submission(s): 2064


Problem Description
Stan and Ollie play the game of multiplication by multiplying an integer p by one of the numbers 2 to 9. Stan always starts with p = 1, does his multiplication, then Ollie multiplies the number, then Stan and so on. Before a game starts, they draw an integer 1 < n < 4294967295 and the winner is who first reaches p >= n.
 

Input
Each line of input contains one integer number n.
 

Output
For each line of input output one line either 

Stan wins. 

or 

Ollie wins.

assuming that both of them play perfectly.
 

Sample Input
  
  
162 17 34012226
 

Sample Output
  
  
Stan wins. Ollie wins. Stan wins.
 

Source
 

这份代码来自爱酱喵好像,DP求博弈的其实跟求SG函数很相似,这个思路值得借鉴,但是代码还是不太懂,贴码备用

#define DeBUG
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <vector>
#include <stack>
#include <queue>
#include <string>
#include <set>
#include <sstream>
#include <map>
#include <list>
#include <bitset>
using namespace std ;
#define zero {0}
#define INF 0x3f3f3f3f
#define EPS 1e-6
#define TRUE true
#define FALSE false
typedef long long LL;
const double PI = acos(-1.0);
//#pragma comment(linker, "/STACK:102400000,102400000")
inline int sgn(double x)
{
    return fabs(x) < EPS ? 0 : (x < 0 ? -1 : 1);
}
#define N 100005
const int off2[] = {1, 0, 2, 0, 1, 0, 3, 0};
const int off3[] = {0, 1, 0, 0, 1, 0, 0, 2};
const int off5[] = {0, 0, 0, 1, 0, 0, 0, 0};
const int off7[] = {0, 0, 0, 0, 0, 1, 0, 0};
int dp[40][40][40][40][2];
long long n;
long long pow_mod(long long a, int b)
{
    long long ans = 1, tmp = a;
    while (b > 0)
    {
        if (b % 2 != 0)
            ans *= tmp;
        b /= 2;
        tmp *= tmp;
    }
    return ans;
}
int DP(int c2, int c3, int c5, int c7, int f)
{
    long long tmp = pow_mod(2, c2) * pow_mod(3, c3) 
    * pow_mod(5, c5) * pow_mod(7, c7);
    if (tmp >= n)
        return 1 - f;
    if (dp[c2][c3][c5][c7][f] != -1)
        return dp[c2][c3][c5][c7][f];
    int ans;
    if (f == 0)
    {
        ans = 1;
        for (int i = 0; i < 8; i++)
        {
            int cc2 = c2 + off2[i], cc3 = c3 + off3[i],
             cc5 = c5 + off5[i], cc7 = c7 + off7[i];
            if (DP(cc2, cc3, cc5, cc7, 1 - f) < ans)
            {
                ans = 0;
                break;
            }
        }
    }
    else
    {
        ans = 0;
        for (int i = 0; i < 8; i++)
        {
            int cc2 = c2 + off2[i], cc3 = c3 + off3[i],
             cc5 = c5 + off5[i], cc7 = c7 + off7[i];
            if (DP(cc2, cc3, cc5, cc7, 1 - f) > ans)
            {
                ans = 1;
                break;
            }
        }
    }
    return dp[c2][c3][c5][c7][f] = ans;
}
int main()
{
#ifdef DeBUGs
    freopen("C:\\Users\\Sky\\Desktop\\1.in", "r", stdin);
#endif
    while (cin >> n)
    {
        memset(dp, -1, sizeof(dp));
        if (DP(0, 0, 0, 0, 0) == 0)
            printf("Stan wins.\n");
        else
            printf("Ollie wins.\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值