hdu 2222 Keywords Search

Online Judge Online Exercise Online Teaching Online Contests Exercise Author
F.A.Q
Hand In Hand
Online Acmers
Forum | Discuss
Statistical Charts
Problem Archive
Realtime Judge Status
Authors Ranklist

 C/C++/Java Exams     

ACM Steps
Go to Job
Contest LiveCast
ICPC@China
Best Coder beta
VIP | STD Contests
Virtual Contests
DIY | Web-DIY beta
Recent Contests
Author dddj123
Mail Mail 0(0)
Control Panel Control Panel
Sign Out Sign Out
(点击查看详情)杭电ACM-LCY算法培训“进阶班”
Keywords Search
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 95650 Accepted Submission(s): 33171

Problem Description
In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.

Input
First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters ‘a’-‘z’, and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.

Output
Print how many keywords are contained in the description.

Sample Input
1
5
she
he
say
shr
her
yasherhs

Sample Output
3
AC自动机模板题

#include<bits/stdc++.h>
using namespace std;

const int maxn = 100007;
char s[107], text[1000010];
int trie[1000007][26];//字典树,储存的是节点的编号
int fail[1000007];
int mark[1000007];//词典结束的标志
int pos = 1;//节点编号

void Insert(char s[])
{
	int len = strlen(s), u = 0,n=0;
	for (int i = 0;i<strlen(s);i++)
	{
		n = s[i] - 'a';
		if(trie[u][n]==0)
			trie[u][n] = pos++;
		u = trie[u][n];
	}
	mark[u]++;
}

void Build()
{
	queue<int> q;
	for (int i = 0;i<26;i++)//把第一层节点的fail指向根节点
	{
		if(trie[0][i]!=0)
		{
			fail[trie[0][i]] = 0;
			q.push(trie[0][i]);
		}
	}

	while(!q.empty())
	{
		int u = q.front();
		q.pop();
		for (int i = 0;i<26;i++)
		{
			if(trie[u][i]!=0)
			{
				fail[trie[u][i]] = trie[fail[u]][i];
				q.push(trie[u][i]);
			}
			else
				trie[u][i] = trie[fail[u]][i];
		}
	}
}

int querry(char s[])
{
	int len = strlen(s), u = 0, ans = 0;//表示层数和答案
	for (int i = 0;i<len;i++)
	{
		u = trie[u][s[i] - 'a'];
		for (int j = u;j&&~mark[j];j=fail[j])
		{
			ans += mark[j];
			mark[j] = -1;
		}
	}
	return ans;
}


int main()
{
	//freopen("11.txt", "r", stdin);
	int t,n;
	scanf("%d", &t);
	while(t--)
	{
		memset(trie, 0, sizeof(trie));
		memset(fail, 0, sizeof(fail));
		memset(mark, 0, sizeof(mark));
		pos = 1;

		scanf("%d", &n);
		for (int i = 0;i<n;i++)
		{
			scanf("%s", s);
			Insert(s);
		}
		Build();
		scanf("%s", text);
		printf("%d\n", querry(text));
	}

	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值