RubyGems发布1.1.0版本,已能够工作在Rubinius之上

作者 Werner Schuster译者 高昂 发布于 2008年3月31日 下午11时4分

RubyGems的开发者 Eric Hodel公布了 RubyGems 1.1.0版本发布的消息。(关于RubyGems过去、现在、未来发展的讨论,可以参看 InfoQ在RubyConf 2007大会上对Eric Hodel所做的采访)。

新版RubyGems的特性包括:
  • 在索引更新方面,RubyGems现在使用了持久连接,使得索引更新方面的效率更高。
  • 默认情况下,RubyGems仅从默认的索引进行更新,目前从更新列表中去除的候选gems大约在1/4左右。实际的索引更新比这要快的多。
    • gem list -r命令可以只显示最新的gem版本,使用参数--all可以查看所有的gem包。
  • gem spec可以从.gem文件中提取规范说明。
  • gem query --installed用来辅助检查gem包进行的自动操作。

全部的特性更改可以查看1.1.0版本的修改记录

最为简便的更新方法就是使用命令(参照发布说明):

gem update --system  (你需要admin或root的权限) 
注意:如果你在使用旧的RubyGems版本(低于0.8.5),Eric建议你使用命令:
gem install rubygems-update (当然,你需要admin或root的权限) 
update_rubygems             (这里也需要admin或root的权限) 
或简单的 在RubyForge上下载RubyGems 1.1.0,之后进入到解压缩后的目录中执行:
ruby setup.rb (你需要具备admin或root的权限)  
在与此相关的新闻中,比方说Eric在 Engine Yard押宝Rubinius一文中的报道,Eric已经在为RubyGems可以运行在Rubinius之上而努力。正如 Michael Klishin关于在Rubinius上通过RubyGems安装Rails的文章所写,这些努力看起来已经有了不小的进展,随后Eric也宣布 Gems已经包含在Rubinius之中:
Lincoln Stoll帮助我从RubyGems中去除最后的几个bug之后,我们将其整合在Rubinius之中。我们决定就像rbx编译或rbx描述一样,让它成为一个rbx gem子命令。目前仍然有一些小的不足存在于RubyGems之中,也就是由于mkmf.rb目前还无法工作在Rubinius之上,所以使用拓展来安装gems还存在问题。

Lincoln同样也发现并修补了RDoc在向后兼容性方面的几个问题,所以目前RubyGems和RDoc都可以顺利工作在Rubinius之上。
查看英文原文: RubyGems: 1.1.0 released, now works on Rubinius
  • 0
    点赞
  • 0
    评论
  • 0
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值