Ubuntu16.04下源码安装go1.10.1编译器

Ubuntu下直接安装go1.10.1版本的go语言编译器需要依赖go1.4版本。所以在安装1.4版本以上的时候,需要安装1.4版本。

设置环境变量

sudo vim /etc/profile

在结尾处添加

 export GOROOT=$HOME/go
 export PATH=$PATH:$GOROOT/bin
 export GOPATH=$HOME/Applications/Go

使配置文件生效

source /etc/profile

安装C 工具

sudo apt-get install bison ed gawk gcc libc6-dev make

安装1.4

下载地址 https://golang.org/dl/(需要翻墙)
如果需要安装1.4以上的版本,需要把1.4版本一起下载。

tar -zxvf go1.4.linux-amd64.tar.gz

将文件移到/home/xxx,xxx为计算机名,并将文件名改为go1.4。如果已经在该目录下,则只把文件名改为go1.4即可。

mv go  /home/xxx/go1.4

安装1.4编译器

cd go1.4/src/
sudo CGO_ENABLED=0 ./make.bash

安装1.10.1

解压1.10.1版本

tar -zxvf go1.10.linux-amd64.tar.gz
mv go /home/xxx # xxx为计算机名 

安装1.10.1

cd /home/xxx/go/src
./all.bash

安装成功如下图所示
success

测试

在完成安装后可输入go env,如果显示类似以下内容,则表示成功

GOARCH="amd64"
GOBIN=""
GOCACHE="/home/yao/.cache/go-build"
GOEXE=""
GOHOSTARCH="amd64"
GOHOSTOS="linux"
GOOS="linux"
GOPATH="/home/yao/Applications/Go"
GORACE=""
GOROOT="/home/yao/go"
GOTMPDIR=""
GOTOOLDIR="/home/yao/go/pkg/tool/linux_amd64"
GCCGO="gccgo"
CC="gcc"
CXX="g++"
CGO_ENABLED="1"
CGO_CFLAGS="-g -O2"
CGO_CPPFLAGS=""
CGO_CXXFLAGS="-g -O2"
CGO_FFLAGS="-g -O2"
CGO_LDFLAGS="-g -O2"
PKG_CONFIG="pkg-config"
GOGCCFLAGS="-fPIC -m64 -pthread -fmessage-length=0 -fdebug-prefix-map=/tmp/go-build612857100=/tmp/go-build -gno-record-gcc-switches"

如果没有,也可能是环境变量没有生效,重启一下电脑试试

代码测试
新建一个hello.go文件,输入以下内容

 package main

 func main() {
     println("Hello", "world")
 }

运行

go run hello.go

会输出Hello world

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
©️2022 CSDN 皮肤主题:1024 设计师:我叫白小胖 返回首页
评论

打赏作者

Mr_姚

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值