hdu 4104 Discount(巧妙递推&思维)

Discount

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1073    Accepted Submission(s): 646


Problem Description

All the shops use discount to attract customers, but some shops doesn’t give direct discount on their goods, instead, they give discount only when you bought more than a certain amount of goods. Assume a shop offers a 20% off if your bill is more than 100 yuan, and with more than 500 yuan, you can get a 40% off. After you have chosen a good of 400 yuan, the best suggestion for you is to take something else to reach 500 yuan and get the 40% off.
For the customers’ convenience, the shops often offer some low-price and useful items just for reaching such a condition. But there are still many customers complain that they can’t reach exactly the budget they want. So, the manager wants to know, with the items they offer, what is the minimum budget that cannot be reached. In addition, although the items are very useful, no one wants to buy the same thing twice.
 

Input
The input consists several testcases.
The first line contains one integer N (1 <= N <= 1000), the number of items available.
The second line contains N integers P i (0 <= P i <= 10000), represent the ith item’s price.

 

Output
Print one integer, the minimum budget that cannot be reached.
 

Sample Input
  
  
4 1 2 3 4
 

Sample Output
  
  
11
 

Source
 

Recommend
lcy
 

题意:

给你n个基本值。问你这个n个基本值不能组合得到最小的值。每个基本值只能使用一次。

思路:

开始想用01背包做。可惜内存开不下。果断去啃线段树去了。。。思维的深度还不够。。

数学归纳法。我们假定。前i个基本值已经能够1->sum范围的值了。现在加入a[i+1]。

如果a[i+1]>sum+1那么可以肯定前i+1个基本值不能组合得到sum+1。

否侧可以表示出1->sum+a[i+1]的值。因为假如要表示v>sum。那么v-a[i+1]正好在1->sum范围内。

所以可以先对基本值排序。然后递推。排序是为了找到最小的不能表示的值。

详细见代码:

#include <iostream>
#include<algorithm>
#include<stdio.h>
#include<string.h>
using namespace std;

int a[1010];
int main()
{
    int i,n,sum;

    while(~scanf("%d",&n))
    {
        for(i=0;i<n;i++)
            scanf("%d",a+i);
        sort(a,a+n);
        sum=0;
        for(i=0;i<n;i++)
        {
            if(sum+1<a[i])
                break;
            else
                sum+=a[i];
        }
        printf("%d\n",sum+1);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值