poj 3134 Power Calculus(迭代加深dfs)

Power Calculus
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 1615 Accepted: 856

Description

Starting with x and repeatedly multiplying by x, we can compute x31 with thirty multiplications:

x2 = x × xx3 = x2 × xx4 = x3 × x, …, x31 = x30 × x.

The operation of squaring can be appreciably shorten the sequence of multiplications. The following is a way to compute x31 with eight multiplications:

x2 = x × xx3 = x2 × xx6 = x3 × x3x7 = x6 × xx14 = x7 × x7x15 = x14 × xx30 = x15 × x15x31 = x30 × x.

This is not the shortest sequence of multiplications to compute x31. There are many ways with only seven multiplications. The following is one of them:

x2 = x × x, x4 = x2 × x2x8 = x4 × x4x8 = x4 × x4x10 = x8 × x2x20 = x10 × x10x30 = x20 × x10x31 = x30 × x.

If division is also available, we can find a even shorter sequence of operations. It is possible to compute x31 with six operations (five multiplications and one division):

x2 = x × xx4 = x2 × x2x8 = x4 × x4x16 = x8 × x8x32 = x16 × x16x31 = x32 ÷ x.

This is one of the most efficient ways to compute x31 if a division is as fast as a multiplication.

Your mission is to write a program to find the least number of operations to compute xn by multiplication and division starting with x for the given positive integern. Products and quotients appearing in the sequence should be x to a positive integer’s power. In others words, x−3, for example, should never appear.

Input

The input is a sequence of one or more lines each containing a single integer nn is positive and less than or equal to 1000. The end of the input is indicated by a zero.

Output

Your program should print the least total number of multiplications and divisions required to compute xn starting with x for the integer n. The numbers should be written each in a separate line without any superfluous characters such as leading or trailing spaces.

Sample Input

1
31
70
91
473
512
811
953
0

Sample Output

0
6
8
9
11
9
13
12

Source

题意

算x^n的快速乘法。算过的结果可以利用。乘和除都可以问最少的运算次数。

思路:

由于涉及到最少次数。想用bfs但是。bfs会出问题。因为求解x^n的过程中只能使用已算出的结果。但是bfs不能确定某个状态时那些结果已经算出。所以只能用dfs来求解。但是盲目用dfs每次搜到底的话。时间开销太大。但是我们大概知道需要的运算次数。所以我们可以逐渐加深的来搜这样就可以最快的找到解了。

详细见代码:

#include<algorithm>
#include<iostream>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<math.h>
#include<vector>
#include<string>
#include<queue>
#include<set>
#include<map>
//#pragma comment(linker,"/STACK:1024000000,1024000000")
using namespace std;
const int INF=0x3f3f3f3f;
const double eps=1e-8;
const double PI=acos(-1.0);
const int maxn=100010;
typedef __int64 ll;
int deep,n,get;
int have[1010];//have[i]第i层得到的数
void iddfs(int dep)
{
    int i,tp;
    if(get||dep>deep||have[dep]<<(deep-dep)<n)//若i次已得到x^m。那么n此处最大能得到x^(m*2^(n-i))。若这个值还小于目标值肯定就不可能了。
        return ;
    if(have[dep]==n)
    {
        get=1;
        return ;
    }
    for(i=0;i<=dep;i++)
    {
        tp=have[i]+have[dep];//乘
        if(tp<2000)
        {
            have[dep+1]=tp;
            iddfs(dep+1);
        }
        tp=fabs(have[dep]*1.0-have[i]);//除
        if(tp<2000)
        {
            have[dep+1]=tp;
            iddfs(dep+1);
        }
    }
}
int main()
{
    have[0]=1;
    while(scanf("%d",&n),n)
    {
        get=0;
        deep=-1;
        while(!get)
        {
            deep++;//加深
            iddfs(0);
        }
        printf("%d\n",deep);
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值