hdu 1085 Holding Bin-Laden Captive!

Holding Bin-Laden Captive!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11609    Accepted Submission(s): 5202


Problem Description
We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China!
“Oh, God! How terrible! ”



Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up!
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!
 

Input
Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.
 

Output
Output the minimum positive value that one cannot pay with given coins, one line for one case.
 

Sample Input
  
  
1 1 3 0 0 0
 

Sample Output
  
  
4
 

Author
lcy
 本来是一道母函数的题。用背包又写了下。经总结。背包可以解决通过组合某个值出不出现。把价值和花费设为一样。能组合得到的值的最终价值就为本身。或者解决每个物品可以用无数次问有多少方法数的问题。或每件物品只能用一次的问题。详情见我博客。
#include<stdio.h>
#include<string.h>

int f[100010];
int va[3]= {1,2,5};
int ma;
int maxx(int a,int b)
{
    return a>b?a:b;
}
void zero(int val,int cost)//01背包求解。val为价值。cost为花费下同
{
    int i;
    for(i=ma; i>=cost; i--)
        f[i]=maxx(f[i],f[i-cost]+val);
}
void complete(int val,int cost)//完全背包求解
{
    int i;
    for(i=cost; i<=ma; i++)
        f[i]=maxx(f[i],f[i-cost]+val);
}
void multiply(int val,int cost,int amount)//混合背包求解
{
    int k;
    if(cost*amount>=ma)//如果数目充足转化为完全背包
    {
        complete(val,cost);
        return ;
    }
    for(k=1; k<amount; k<<=1)//二进制优化。多重背包
    {
        zero(val*k,cost*k);
        amount-=k;
    }
    zero(amount*val,amount*cost);
}
int main()
{
    int i,num[3];

    while(scanf("%d%d%d",&num[0],&num[1],&num[2]),num[0]||num[1]||num[2])
    {
        ma=1*num[0]+2*num[1]+5*num[2];
        memset(f,0,sizeof f);
        for(i=0; i<3; i++)//遍历每种选择。
            multiply(va[i],va[i],num[i]);
        for(i=1; i<=ma+1; i++)//答案可能超过ma
           if(f[i]!=i)
           {
               printf("%d\n",i);
               break;
           }
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值