1059. C语言竞赛(20)

C语言竞赛是浙江大学计算机学院主持的一个欢乐的竞赛。既然竞赛主旨是为了好玩,颁奖规则也就制定得很滑稽:

0. 冠军将赢得一份“神秘大奖”(比如很巨大的一本学生研究论文集……)。
1. 排名为素数的学生将赢得最好的奖品 —— 小黄人玩偶!
2. 其他人将得到巧克力。

给定比赛的最终排名以及一系列参赛者的ID,你要给出这些参赛者应该获得的奖品。

输入格式:

输入第一行给出一个正整数N(<=10000),是参赛者人数。随后N行给出最终排名,每行按排名顺序给出一位参赛者的ID(4位数字组成)。接下来给出一个正整数K以及K个需要查询的ID。

输出格式:

对每个要查询的ID,在一行中输出“ID: 奖品”,其中奖品或者是“Mystery Award”(神秘大奖)、或者是“Minion”(小黄人)、或者是“Chocolate”(巧克力)。如果所查ID根本不在排名里,打印“Are you kidding?”(耍我呢?)。如果该ID已经查过了(即奖品已经领过了),打印“ID: Checked”(不能多吃多占)。

输入样例:
6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222
输出样例:
8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?

AC~开心啦厚厚厚~


#include<iostream>
#include<stdio.h>
#include<math.h>
using namespace std;
int arr[10000];
int check[10000]; 
int find ( int x ){
	if ( x==0 || x ==1 || x == -1 ) return 0;
	for ( int i = 2; i <= sqrt(x) ; i++){
		if ( x % i == 0) return 0;
	}
	return 1;
}
//是输完才出结果 
int main(){
	int n , t;
	cin >> n;
	int count = 1;
	while ( count <= n ){
		cin >> t;
		arr[t] = count;
		count++;
	}
	int seckn,s;
	cin >> seckn;
	count = 0;
	while ( count < seckn){
		cin >> s;
		check[count] = s;
		count++;
	}
	count = 0;	
	while ( count < seckn ){
			
		if ( arr[check[count]] == 1 ){
			printf ( "%04d: Mystery Award\n" , check[count] );
			arr[check[count]] = -1;	
		}else if ( find ( arr[check[count]] )){
			printf ( "%04d: Minion\n" , check[count] );
			arr[check[count]] = -1;
		}else if ( arr[check[count]] == -1 ) {
			printf ( "%04d: Checked\n" , check[count] );
			
		}else if ( arr[check[count]] == 0 ) {
			printf ( "%04d: Are you kidding?\n" , check[count] );
		}else{
			printf ( "%04d: Chocolate\n" , check[count] );
			arr[check[count]] = -1;
		}
		count++;
	}
	return 0;
}

/*
	for ( int i = 0; i < 10000; i++ )
		if ( arr[i] != 0 )
			cout << arr[i];

*/


注意:

1不是一边输入一边输出的,是输入完测试样例才全部输出的。

2 获得Chocolate的同学也只能领取一次


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值