HDOJ--1028Ignatius and the Princess III!!母函数

原题链接


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
  
  
4 10 20
 

Sample Output
  
  
5 42 627
 
题目大意:每个数可以有几个组合,给你一个数请你输出可以组合个个数,3+1和1+3是同样的。
思路:母函数。

代码:
#include<stdio.h>
#include<string.h>

#define max 120 
int a[max+1];  //数组a代表最后的结果 
int b[max+1];  //数组b代表中间值 

int main()
{
	 int i,j,k,N;
	 memset(a,0,sizeof(a));
	 memset(b,0,sizeof(b));
	 a[0]=1;
	 for(i=1;i<=max;i++)
	 {
	 	for(j=0;j*i<=max;j++)
	 	{
	 		for(k=0;k+j*i<=max;k++)
	 		{
	 			b[k+j*i]+=a[k];
			}
		}
		for(j=0;j<=max;j++)
		{
			a[j]=b[j];
		}
		memset(b,0,sizeof(b));
	 }
	 while(scanf("%d",&N)!=EOF)
	 {
	 	printf("%d\n",a[N]);
	 }
	
	return 0;
}

随意转载

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值