ACM第八届山东省赛 G-Sum of power

G-Sum of power

Time Limit: 1000 ms   Memory Limit: 65536 KiB

Problem Description
Calculate ni=1im ∑ i = 1 n i m mod (1000000000+7) for given n,m.

Input
Input contains two integers n,m(1≤n≤1000,0≤m≤10).

Output
Output the answer in a single line.

Example Input
10 0

Example Output
10

题目链接:https://acm.sdut.edu.cn/onlinejudge2/index.php/Home/Contest/contestproblem/cid/2164/pid/3899

本题直接使用快速幂即可

参考代码

#include <stdio.h>
#define MOD 1000000007
long long powf(int a, int b){
    long long r;
    if(b == 1)
        return a;
    if(b == 0)
        return 1;
    r = powf(a, b/2);
    r = r*r%MOD;
    if(b%2 == 1)
        r = r*a%MOD;
    return r;
}
int main(void)
{
    int n, m;
    int i, j, k;
    long long res = 0;
    scanf("%lld%lld", &n, &m);
    for(i = 1; i <= n; i++){
        res += powf(i, m);
        res %= MOD;
    }
    printf("%lld\n", res);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值