UVA Help is needed for Dexter 11384 (递归)

Help is needed for Dexter

Dexter is tired of Dee Dee. So he decided to keep Dee Dee busy in a game. The game he planned forher is quite easy to play but not easy to win at least not for Dee Dee. But Dexter does not have timeto spend on this silly task, so he wants your help.

There will be a button, when it will be pushed a random number N will be chosen by computer.Then on screen there will be numbers from 1 to N. Dee Dee can choose any number of numbers fromthe numbers on the screen, and then she will command computer to subtract a positive number chosenby her (not necessarily on screen) from the selected numbers. Her objective will be to make all thenumbers 0.

For example if N = 3, then on screen there will be 3 numbers on screen: 1, 2, 3. Say she now selects1 and 2. Commands to subtract 1, then the numbers on the screen will be: 0, 1, 3. Then she selects 1and 3 and commands to subtract 1. Now the numbers are 0, 0, 2. Now she subtracts 2 from 2 and allthe numbers become 0.

Dexter is not so dumb to understand that this can be done very easily, so to make a twist he willgive a limit L for each N and surely L will be as minimum as possible so that it is still possible to winwithin L moves. But Dexter does not have time to think how to determine L for each N, so he asksyou to write a code which will take N as input and give L as output.

Input

Input consists of several lines each with N such that 1 ≤ N ≤ 1, 000, 000, 000. Input will be terminatedby end of file.

Output

For each N output L in separate lines.

Sample Input

1

2

3

Sample Output

2

2

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define ll long long
#define N 10010
using namespace std;
int f(int n)
{
	return n==1?1:f(n/2)+1;
} 
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		printf("%d\n",f(n));
	}
	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值