compileSdkVersion 'android-24' requires JDK 1.8 or later to compile.


报错误   Error:Execution failed for task ':app:compileDebugJavaWithJavac'.> compileSdkVersion 'android-24' requires JDK 1.8 or later to compile.


把版本号统一一下,主要是下面这几个参数的值

    compileSdkVersion 23
    buildToolsVersion "23.0.0"
    targetSdkVersion 23
dependencies {
    compile 'com.android.support:recyclerview-v7:23.1.1'    
   }


apply plugin: 'com.android.application'

android {
    compileSdkVersion 23
    buildToolsVersion "23.0.3"
    defaultConfig {
        applicationId "com.example.recycleviewslidingdelydemo"
        minSdkVersion 15
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"
            multiDexEnabled true
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}
dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    testCompile 'junit:junit:4.12'
    compile 'com.android.support:appcompat-v7:23.1.1'
    compile files('libs/nineoldandroids-2.4.0.jar')
    compile 'com.android.support:recyclerview-v7:23.1.1'
    compile 'com.android.support:design:23.1.1'

}


阅读更多
文章标签: compileSdkVersion
上一篇友盟第三方(微信)登录讲解
下一篇修改Android studio中的包名
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭