习题3-5 Puzzle UVa227

题目描述:
A children’s puzzle that was popular 30 years ago consisted of a 5×5 frame which contained 24 small
squares of equal size. A unique letter of the alphabet was printed on each small square. Since there
were only 24 squares within the frame, the frame also contained an empty position which was the same
size as a small square. A square could be moved into that empty position if it were immediately to the
right, to the left, above, or below the empty position. The object of the puzzle was to slide squares
into the empty position so that the frame displayed the letters in alphabetical order.
The illustration below represents a puzzle in its original configuration and in its configuration after
the following sequence of 6 moves:
1) The square above the empty position moves.
2) The square to the right of the empty position moves.
3) The square to the right of the empty position moves.
4) The square below the empty position moves.
5) The square below the empty position moves.
6) The square to the left of the empty position moves.
Input
Input for your program consists of several puzzles. Each is described by its initial configuration and
the sequence of moves on the puzzle. The first 5 lines of each puzzle description are the starting
configuration. Subsequent lines give the sequence of moves.
The first line of the frame display corresponds to the top line of squares in the puzzle. The other
lines follow in order. The empty position in a frame is indicated by a blank. Each display line contains
exactly 5 characters, beginning with the character on the leftmost square (or a blank if the leftmost
square is actually the empty frame position). The display lines will correspond to a legitimate puzzle.
The sequence of moves is represented by a sequence of As, Bs, Rs, and Ls to denote which square
moves into the empty position. A denotes that the square above the empty position moves; B denotes
that the square below the empty position moves; L denotes that the square to the left of the empty
position moves; R denotes that the square to the right of the empty position moves. It is possible that
there is an illegal move, even when it is represented by one of the 4 move characters. If an illegal move
occurs, the puzzle is considered to have no final configuration. This sequence of moves may be spread
over several lines, but it always ends in the digit 0. The end of data is denoted by the character Z.
Output
Output for each puzzle begins with an appropriately labeled number (Puzzle #1, Puzzle #2, etc.). If
the puzzle has no final configuration, then a message to that effect should follow. Otherwise that final
configuration should be displayed.
Format each line for a final configuration so that there is a single blank character between two
adjacent letters. Treat the empty square the same as a letter. For example, if the blank is an interior
position, then it will appear as a sequence of 3 blanks | one to separate it from the square to the left,
one for the empty position itself, and one to separate it from the square to the right.
Separate output from different puzzle records by one blank line.
Note: The first record of the sample input corresponds to the puzzle illustrated above.
Sample Input
TRGSJ
XDOKI
M VLN
WPABE
UQHCF
ARRBBL0
ABCDE
FGHIJ
KLMNO
PQRS
TUVWX
AAA
LLLL0
ABCDE
FGHIJ
KLMNO
PQRS
TUVWX
AAAAABBRRRLL0
Z
Sample Output
Puzzle #1:
T R G S J
X O K L I
M D V B N
W P A E
U Q H C F
Puzzle #2:
A B C D
F G H I E
K L M N J
P Q R S O
T U V W X
Puzzle #3:
This puzzle has no final configuration.
注意,不要复制我这个样例,最后一个是空格的我没打。 原题这里一样,把我坑了好久
大概意思就是有个5*5的网格,其中一个格子是空的,其他格子各有一个字母。一共有四种指令:A,B,L,R,分别表示把空格上方、下方、左、右的相邻字母移到空格中。输入初始网格和指令序列(以0结束)‘注意:指令可以有多行构成一个指令’,输出执行完指令的网格。如果有非法指令,就输出“This puzzle has no final configuration.”
上代码;

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
char p[10][10];//存字母网格
int dx,dy;//空格位置
void read(){//读入
    for(int i=1;i<=4;i++){
        gets(p[i]);
    }
}
void put(){//输出
    int i,j;
    for(i=0;i<5;i++){
        for(j=0;j<4;j++){
            printf("%c ",p[i][j]);
        }
        printf("%c\n",p[i][j]);
    }
}
bool convert(char dir){//转换
    int flag=1;
    int x=dx,y=dy;
    if(dir=='A')
        x=dx-1;
    else if(dir=='B')
        x=dx+1;
    else if(dir=='L')
        y=dy-1;
    else if(dir=='R')
        y=dy+1;
    if(x<0||x>4||y<0||y>4)
        flag=0;
    else{
        p[dx][dy]=p[x][y];
        p[x][y]=' ';
        dx=x;dy=y;
    }
    if(flag)
        return true;
    else
        return false;
}
int main(){
    string zl,str;
    int len,flag,num=0;
    while(1){
        flag=1;
        if(num!=0)
            cin.get();
        getline(cin,str);//先读一行判读是不是‘Z’
        if(str[0]=='Z')
            break;
        if(num!=0)
            printf("\n");
        for(int i=0;i<5;i++){
            p[0][i]=str[i];
        }
        read();
        for(int i=0;i<5;i++){
            for(int j=0;j<5;j++){
                if(p[i][j]==' '){
                    dx=i;
                    dy=j;
                }
            }
        }
        zl.clear();
        while(1){//读入指令
            string temp;
            cin>>temp;
            zl+=temp;
            len=temp.length();
            if(temp[len-1]=='0')
                break;
            else
                continue;
        }
        len=zl.length();
        for(int i=0;i<len-1;i++){
            if(convert(zl[i]))
                continue;
            else{
                flag=0;
                break;
            }
        }
        printf("Puzzle #%d:\n",++num);
        if(flag==0)
            printf("This puzzle has no final configuration.\n");
        else
            put();
    }
return 0;
}

总结:模拟题讲究的就是一个细心和严密的逻辑,这种题一定要事先想好整体框架再下手。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值