Calculation 2
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 2511 Accepted Submission(s): 1048
Problem Description
Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.
Input
For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.
Output
For each test case, you should print the sum module 1000000007 in a line.
Sample Input
3 4 0
Sample Output
0 2
Author
GTmac
Source
Recommend
欧拉函数性质:N>1,不大于N且和N互素的所有正整数的和是 1/2*M*eular(N)。
#include<stdio.h>
#include<algorithm>
using namespace std;
typedef __int64 LL;
LL phi(LL n){
LL i,res=n;
for(i=2;i*i<=n;i++)
if(n%i==0){
res=res/i*(i-1);
while(n%i==0)n/=i;
}
if(n>1) res=res/n*(n-1);
return res;
}
int main()
{
LL N;
while(scanf("%I64d",&N),N){
LL x=(N*(N-1)/2-N*phi(N)/2)%1000000007;
printf("%I64d\n",x);
}
return 0;
}