HDOJ Calculation 2 3501(eular函数)

Calculation 2

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2511    Accepted Submission(s): 1048


Problem Description
Given a positive integer N, your task is to calculate the sum of the positive integers less than N which are not coprime to N. A is said to be coprime to B if A, B share no common positive divisors except 1.
 

Input
For each test case, there is a line containing a positive integer N(1 ≤ N ≤ 1000000000). A line containing a single 0 follows the last test case.
 

Output
For each test case, you should print the sum module 1000000007 in a line.
 

Sample Input
  
  
3 4 0
 

Sample Output
  
  
0 2
 

Author
GTmac
 

Source
 

Recommend
zhouzeyong   |   We have carefully selected several similar problems for you:   3507  3506  3505  3504  3499 

欧拉函数性质:N>1,不大于N且和N互素的所有正整数的和是 1/2*M*eular(N)。

#include<stdio.h>
#include<algorithm>
using namespace std;
typedef __int64 LL;
LL phi(LL n){
	LL i,res=n;
	for(i=2;i*i<=n;i++)
	    if(n%i==0){
	    	res=res/i*(i-1);
	    	while(n%i==0)n/=i;
		}
	if(n>1) res=res/n*(n-1);
	return res;
}
int main()
{
	LL N;
	while(scanf("%I64d",&N),N){
		LL x=(N*(N-1)/2-N*phi(N)/2)%1000000007;
		printf("%I64d\n",x);	
	}
	return 0;
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值