poj1050

To the Max

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 46124 Accepted: 24373

Description
Given a two-dimensional(二维的) array of positive and negative integers, a sub-rectangle is any contiguous(连续的) sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal(最高的) sub-rectangle.
As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and has a sum of 15.

Input
The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output
Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1

8 0 -2

Sample Output

15

Source
Greater New York 2001
大概意思就是从n*n的矩形中求和最大的矩形。
首先自己想,没想出来,后来网上看题解,发现之前做过差不多的一维数组求最大的题目,后来想了下,大概意思懂了,然后提交,A了,就是i从0到n,然后j从i到n取,当某一个i,j时,就当做一维数组处理,k从0到n求列最大值,然后如果为负数,表明前面的数已不能再参与后面的相加了,应该置为0。然后竖着相加。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int num[110][110],dp[110][110];
int main(){
    int n,i,j;
    while(scanf("%d",&n)!=EOF){
        memset(dp,0,sizeof(dp));
        for ( i = 0; i < n; ++i)
        {
            for ( j = 0; j < n; ++j)
            {
                scanf("%d",&num[i][j]);
            }
        }
        int max=0,sum;
        for ( i = 0; i < n; ++i)
        {
            for ( j = i; j < n; ++j)        //从i行到j行
            {
                sum=0;
                for (int k = 0; k < n; ++k)
                {
                    int temp=0;
                    for (int m = i; m <= j; ++m)
                    {
                        temp+=num[k][m];    //竖着加某一列
                    }
                    sum+=temp;
                    if(sum<0)sum=0;         //当加到小于的时候置为0,重新开始加。
                    else if(sum>max)max=sum;
                }
            }
        }
        printf("%d\n", max);


    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值