POJ 1679 判断最小生成树是否唯一

先求一棵最小生成树,再用不在树中的边去替换一条已在树中的边,看是否能生成一棵权值等于原来最小生成树的

The Unique MST

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12208 Accepted: 4219

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties:
1. V' = V.
2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'.

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<vector>
#define M 105
#define Max 10000000
using namespace std;
int n,m;
int map[M][M];
int max_val[M][M];//记录图中任意两点之间最大边的值
int pre[M];
bool v[M][M];
int prime()
{
    int MIN[M];
    bool visited[M];
    int i,j,u,k;
    int min,ans=0;
    memset(visited,false,sizeof(visited));
    memset(pre,0,sizeof(pre));
    memset(max_val,0,sizeof(max_val));
    for(i=1;i<=n;i++)
        MIN[i]=Max;
    MIN[1]=0;
    for(k=0;k<n;k++)
    {
        min=Max;
        for(i=1;i<=n;i++)
        {
            if(!visited[i]&&MIN[i]<min)
            {
                min=MIN[i];
                u=i;
            }
        }
        int p=pre[u];
        max_val[p][u]=min;
        v[p][u]=true;//是所求最小生成树中,标记为true
        v[u][p]=true;
        for(i=1;i<=n;i++)
            if(visited[i])//更新所有已在最小生成树中的点到u的max_val[i][u]
                max_val[i][u]=max_val[i][p]>max_val[p][u]?max_val[i][p]:max_val[p][u];
        visited[u]=true;
        ans+=min;
        for(i=1;i<=n;i++)
        {
            if(!visited[i]&&MIN[i]>map[u][i])
            {
                MIN[i]=map[u][i];
                pre[i]=u;//如果u能把MIN[i]更新,则u是i的pre
            }
        }
    }
    return ans;
}

int main()
{
    int cas,i,j;
    int T,T1;
    bool flag;
    scanf("%d",&cas);
    while(cas--)
    {
        scanf("%d%d",&n,&m);
        for(i=0;i<=n;i++)
            for(j=0;j<=n;j++)
                map[i][j]=Max;
        for(i=0;i<m;i++)
        {
            int a,b,c;
            scanf("%d%d%d",&a,&b,&c);
            map[a][b]=map[b][a]=c;
        }
        memset(v,false,sizeof(v));
        T=prime();//先求出一条最小生成树
        flag=true;
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                if(!v[i][j]&&map[i][j]!=Max)//找一条不在最小生成树中的边(能走通)去替换最小生成树中的一条边
                {
                    //T1=T+map[i][j]-max_val[i][j];
                    if(map[i][j]==max_val[i][j])
                    {
                        flag=false;
                        break;
                    }
                }
            }
            if(flag==false)
                break;
        }
        if(flag)
            printf("%d\n",T);
        else 
            printf("Not Unique!\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值