problem-1426-poj

3 篇文章 0 订阅

点击打开链接

                                                                                                                                        Find The Multiple
Time Limit: 1000MS
Memory Limit: 10000K
Total Submissions: 23546
Accepted: 9720
Special Judge
                              

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111
题意:给你一个数,找出他的倍数(只能由0,1组成) 比如:2的话就是10啦,要注意的就是数过大,整型不行,用上了unsigned long long 型。

可以用深搜,到十九层就可以回溯啦,因为二十层的数太大,内存已经不够啦。

代码演示:

 #include <stdio.h>
    int n,flat;
    unsigned long long b;
    void DFS(unsigned long long a,int step)
    {
        if(flat||step==19)  //如果找到或者到十九层,回溯
        {
            return ;
        }
        if(a%n==0)
        {
            printf("%I64u\n",a);
            flat=1;
            return ;
        }
        else
        {
            DFS(a*10,step+1); //因为就0,1两数,所以就0,1不断深搜
            DFS(a*10+1,step+1);
        }
        return ;
    }
    int main()
    {
        while(scanf("%d",&n),n)
        {
            flat=0;
            DFS(1,0);
        }
        return 0;
    }

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值