#18-3 OJ 287 one +two = 3

题目描述

在这里插入图片描述

输入

在这里插入图片描述

输出

在这里插入图片描述

样例输入

在这里插入图片描述

样例输出

在这里插入图片描述

源代码

#include<stdio.h>
#include<string.h>
int swp(char a[])
{
    int c;
    if(strcmp(a,"zero")==0) c=0;
    else if(strcmp(a,"one")==0) c=1;
    else if(strcmp(a,"two")==0) c=2;
    else if(strcmp(a,"three")==0) c=3;
    else if(strcmp(a,"four")==0) c=4;
    else if(strcmp(a,"five")==0) c=5;
    else if(strcmp(a,"six")==0) c=6;
    else if(strcmp(a,"seven")==0) c=7;
    else if(strcmp(a,"eight")==0) c=8;
    else if(strcmp(a,"nine")==0) c=9;
    return c;
}
int main()
{
    while(1)
	{
		int i,sum1=0,sum2=0,end=0;
		char a[10];
		for(i=0;;i++)
		{	
			scanf("%s",a);
			if(a[0]=='+')break;
			if(swp(a)==0)end++;
			sum1*=10;
			sum1+=swp(a);
		}
		for(i=0;;i++)
		{
			scanf("%s",a);
			if(a[0]=='=')break;
			if(swp(a)==0 && end==1)return 0;
			sum2*=10;
			sum2+=swp(a);
		}
		printf("%d\n",sum1+sum2);
	}
    return 0;
}

关于这题

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值