PAT1023

1023. Have Fun with Numbers (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.
Sample Input:

1234567899

Sample Output:

Yes
2469135798

破解过程:

一开始,想要用next_permutation,其实是想要看投机取巧可不可以通过。

#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <string>
#include <vector>
#include <cstring>
#include <cmath>
#include <set>
#include <queue>
#include <algorithm> 


using namespace std;

long long input,output; 



int main(){


    cin>>input;

    output=2*input;

    string str_in=to_string(input);
    string str_out = to_string(output);


    int flag=0;

//  int length=str_in.length();

    do{

        if(str_out == str_in){
            flag=1;
        }


    }while(next_permutation(str_in.begin(),str_in.end()));


    if(flag){

        cout<<"Yes"<<endl;
    }else{

        cout<<"No"<<endl;
    }

    cout<<output<<endl; 



    return 0;
}



结果:

这里写图片描述

有3个测试点运行超时,那么为什么超时,想想都肯定知道一定是循环的时候出的问题。

其实之前还有其他的思路,不只是这一题,每次做题的时候总是会有很多的种思路,多个思路反而会干扰自己,怎么办?尽量多刷题吧;

第二种想法,就是用建一个散列表,题目已经明显说了1~9的数字,那么可以选择用数组【】或者map,这里我觉得数组应该很方便。试着编一下。

#include <cstdi
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值