poj-Anagram

排序+next_permutation

835:Anagram

总时间限制: 
1000ms 
内存限制: 
65536kB
描述
You are to write a program that has to generate all possible words from a given set of letters. 
Example: Given the word "abc", your program should - by exploring all different combination of the three letters - output the words "abc", "acb", "bac", "bca", "cab" and "cba". 
In the word taken from the input file, some letters may appear more than once. For a given word, your program should not produce the same word more than once, and the words should be output in alphabetically ascending order. 
输入
The input consists of several words. The first line contains a number giving the number of words to follow. Each following line contains one word. A word consists of uppercase or lowercase letters from A to Z. Uppercase and lowercase letters are to be considered different. The length of each word is less than 13.
输出
For each word in the input, the output should contain all different words that can be generated with the letters of the given word. The words generated from the same input word should be output in alphabetically ascending order. An upper case letter goes before the corresponding lower case letter.
样例输入
3
aAb
abc
acba
样例输出
Aab
Aba
aAb
abA
bAa
baA
abc
acb
bac
bca
cab
cba
aabc
aacb
abac
abca
acab
acba
baac
baca
bcaa
caab
caba
cbaa
  • 查看 
  • 提交 
  • 统计 
  • 提问
    • 这个题目只要注意他的排序方式就可以了,“  An upper case letter goes before the corresponding lower case letter.”这句坑爹的话,意思就是A<a<B<b<C<c<D<d........<Z<z
    • 注意cmp也要用在next_permutation中
    • #include<cstdlib>
      #include<cstring>
      #include<cstdio>
      #include<cmath>
      #include<iostream>
      #include<algorithm>
      using namespace std;
      char s[15];
      int f(char x)
      {
          if(x>='a'&&x<='z')
              return (x-'a'+1)*2;
          else
              return (x-'A')*2+1;
      }
      bool cmp(char a,char b)
      {
          return f(a)<f(b);
      }
      int main()
      {
          int t;
          scanf("%d",&t);
          getchar();
          while(t--)
          {
              gets(s);
              int len=strlen(s);
              sort(s,s+len,cmp);
              do
              {
                  printf("%s\n",s);
              }while(next_permutation(s,s+len,cmp));
          }
          return 0;
      }
      



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值