HDU 4405 Aeroplane chess(概率DP)

Aeroplane chess

                                                               Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                             Total Submission(s): 2847    Accepted Submission(s): 1824


Problem Description
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.
 

Input
There are multiple test cases. 
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).  
The input end with N=0, M=0. 
 

Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.
 

Sample Input
  
  
2 0 8 3 2 4 4 5 7 8 0 0
 

Sample Output
  
  
1.1667 2.3441
 

Source

题目链接点击打开链接

题意:飞行棋游戏,要求从0走到n点游戏结束,每次扔色子(1—6概率相同)决定走的步数,同时存在m条飞行航道,每个位置最多有一个航道,从xi到y1不需要扔色子而是直接到达。0<=xi<yi<=n。计算游戏结束时扔色子次数的期望。

思路:dp[i]表示从i到终点扔色子次数的期望次数,a[i]表示第i个位置可以直接飞行到的位置,初始化a[i]=i,若x和y之间存在航道,则a[x]=y;

          状态转移方程:每个面出现的概率p=1.0/6

          如果a[i]!=i;dp[i]=dp[a[i]];否则dp[i]=sum((dp[i+k]+1)*p);

代码:

#include<stdio.h>
#include<string.h>
int main()
{
    int n,m,i,j;int a[100010];double dp[100010];
    while(scanf("%d%d",&n,&m)!=EOF&&n!=0||m!=0)
    {
        for(i=0;i<=n;i++)
        a[i]=i;
        int x,y;
        while(m--)
        {
            scanf("%d%d",&x,&y);
            a[x]=y;
        }
        memset(dp,0,sizeof(dp));
        for(i=n-1;i>=0;i--)
        {
            if(a[i]!=i) dp[i]=dp[a[i]];
            else
            {
                for(j=1;j<=6;j++)
                dp[i]+=(dp[i+j]+1)*1.0/6;
            }
        }
        printf("%.4lf\n",dp[0]);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值