BNUOJ 8108

The Frog's Games

1000ms
65768KB
This problem will be judged on HDU. Original ID:  4004
64-bit integer IO format:  %I64d      Java class name:  Main
Font Size:   
The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they 
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).

Input

The input contains several cases. The first line of each case contains three positive integer L, n, and m. 
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.

Output

For each case, output a integer standing for the frog's ability at least they should have.

Sample Input

6 1 2
2
25 3 3
11 
2
18

Sample Output

4
11

Source

The 36th ACM/ICPC Asia Regional Dalian Site —— Online Contest


#include <iostream>
#include <climits>
#include <cstdio>
#include <algorithm>
using namespace std;
const int N= 500011;
int a[N];
int judge(int k);
int l, n, m;


int main()
{
    while(scanf("%d%d%d",&l,&n, &m)!=EOF)
    {
        a[0]=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        sort(a+1,a+n+1);
        int Max=-1;
        for(int i=1;i<=n;i++)
        {
            Max=max(Max,a[i]-a[i-1]);
        }
        a[n+1]=l;
        a[n+2]=INT_MAX;
        Max=max(Max,a[n+1]-a[n]);
        int li=Max-1,ri=l,mid;
        while(mid=(li+ri)/2,li<ri)
        {
            if(judge(mid))
            {
                ri=mid;
            }
            else
            {
                li=mid+1;
            }
        }
        printf("%d\n",ri);
    }
    return 0;
}


int judge(int k)
{
    int now=0;
    for(int i=1;i<=m;i++)
    {
        int j;
        for(j=now;a[j+1]-a[now]<=k;j++);
        now=j;
        if(now==n+1)
        {
            return 1;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值