HDU 4283 You Are the One(区间DP)

You Are the One
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

  The TV shows such as You Are the One has been very popular. In order to meet the need of boys who are still single, TJUT hold the show itself. The show is hold in the Small hall, so it attract a lot of boys and girls. Now there are n boys enrolling in. At the beginning, the n boys stand in a row and go to the stage one by one. However, the director suddenly knows that very boy has a value of diaosi D, if the boy is k-th one go to the stage, the unhappiness of him will be (k-1)*D, because he has to wait for (k-1) people. Luckily, there is a dark room in the Small hall, so the director can put the boy into the dark room temporarily and let the boys behind his go to stage before him. For the dark room is very narrow, the boy who first get into dark room has to leave last. The director wants to change the order of boys by the dark room, so the summary of unhappiness will be least. Can you help him? 

Input

  The first line contains a single integer T, the number of test cases.  For each case, the first line is n (0 < n <= 100) 
  The next n line are n integer D1-Dn means the value of diaosi of boys (0 <= Di <= 100) 

Output

  For each test case, output the least summary of unhappiness . 

Sample Input

2
  
5
1
2
3
4
5

5
5
4
3
2
2

Sample Output

Case #1: 20
Case #2: 24


有N个人要出场,每个人有个不爽的值,如果他第i个出场 那么 他的愤怒值为 num[i]*(i-1),求怎么样排出场顺序,能使得总得愤怒值最小

这题思维度很大,方法技巧性很强,如果一个人要进小黑屋的话就代表着他要排在后面的已经排好序的顺序后面,而且从小区间开始遍历已经将情况处理到最优,所以换位置不影响后面的最优排序


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int inf = 0x3f3f3f3f;
int dp[110][110], v[110], sum[110];


int main()
{
    int t;
    scanf("%d", &t);
    int ncase=1;
    while(t--)
    {
        int n;
        scanf("%d", &n);
        sum[0]=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d", &v[i]);
            sum[i]=sum[i-1]+v[i];
        }
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            for(int j=i+1;j<=n;j++)
            {
                dp[i][j]=inf;
            }
        }
        for(int len=1;len<n;len++)
        {
            for(int i=1;i+len<=n;i++)
            {
                int j=i+len;
                dp[i][j]=min(dp[i][j],dp[i+1][j]+sum[j]-sum[i]);
                for(int k=i+1;k<=j;k++)
                {
                    dp[i][j]=min(dp[i][j],v[i]*(k-i)+dp[i+1][k]+dp[k+1][j]+(sum[j]-sum[k])*(k-i+1));
                }
            }
        }
        printf("Case #%d: %d\n",ncase++,dp[1][n]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值