hdu 5536 Chip Factory(字典树)

Chip Factory

Time Limit: 18000/9000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 3235    Accepted Submission(s): 1397


Problem Description
John is a manager of a CPU chip factory, the factory produces lots of chips everyday. To manage large amounts of products, every processor has a serial number. More specifically, the factory produces  n  chips today, the  i -th chip produced this day has a serial number  si .

At the end of the day, he packages all the chips produced this day, and send it to wholesalers. More specially, he writes a checksum number on the package, this checksum is defined as below:
maxi,j,k(si+sj)sk

which  i,j,k  are three  different integers between  1  and  n . And   is symbol of bitwise XOR.

Can you help John calculate the checksum number of today?
 

Input
The first line of input contains an integer  T  indicating the total number of test cases.

The first line of each test case is an integer  n , indicating the number of chips produced today. The next line has  n  integers  s1,s2,..,sn , separated with single space, indicating serial number of each chip.

1T1000
3n1000
0si109
There are at most  10  testcases with  n>100
 

Output
For each test case, please output an integer indicating the checksum number in a line.
 

Sample Input
  
  
2 3 1 2 3 3 100 200 300
 

Sample Output
  
  
6 400

N^2选i,j然后贪心选k,用字典树实现


#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<cmath>
#include<string>
#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
const int N =1e6+100;
int node[N][3], a[N], cnt, res[N];
void add(int x,int d)
{
    int u=0;
    for(int i=30;i>=0;i--)
    {
        int v=(x>>i)&1;
        if(node[u][v]==-1)
        {
            node[u][v]=cnt;
            res[cnt]=0,node[cnt][0]=node[cnt][1]=-1;
            cnt++;
        }
        u=node[u][v];
        res[u]+=d;
    }
}
int get(int v)
{
    int ans=v, u=0;
    for(int i=30;i>=0;i--)
    {
        int d=(v>>i)&1;
        if(node[u][d^1]!=-1&&res[node[u][d^1]])
        {
            u=node[u][d^1];
            ans|=(1<<i);
        }
        else
        {
            if(node[u][d]!=-1)
            {
                if(d==1)ans^=(1<<i);
            }
            u=node[u][d];
        }
    }
    return ans;
}

int main()
{
    int t;
    scanf("%d", &t);
    while(t--)
    {
        int n;
        scanf("%d", &n);
        node[0][0]=-1,node[0][1]=-1;
        res[0]=0, cnt=1;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            add(a[i],1);
        }
        int ans=0;
        for(int i=0;i<n;i++)
        {
            add(a[i],-1);
            for(int j=i+1;j<n;j++)
            {
                add(a[j],-1);
                ans=max(ans,get(a[i]+a[j]));
                add(a[j],1);
            }
            add(a[i],1);
        }
        printf("%d\n",ans);
    }
    return 0;
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值